Problem-1008: Elevator

6 篇文章 0 订阅

杭电1008题.

/*
==========================================================================================
Problem Description
The highest building in our city has only one elevator. A request list is made up with N
positive numbers. The numbers denote at which floors the elevator will stop, in specified
order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down
one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests
on the list. The elevator is on the 0th floor at the beginning and does not have to return
to the ground floor when the requests are fulfilled.

Input
There are multiple test cases. Each case contains a positive integer N, followed by N
positive numbers. All the numbers in the input are less than 100. A test case with N = 0
denotes the end of input. This test case is not to be processed.

Output
Print the total time on a single line for each test case.

Sample Input
1 2
3 2 3 1
0

Sample Output
17
41
=============================================================================================
*/
#include <stdio.h>
#include <malloc.h>

int main(void)
{
    int n = 0;
    int i = 0;
    int TotalTime = 0;
    int *p  = NULL;

    while (scanf("%d", &n) != EOF)
    {
        if (0 == n) {
            break;
        }
        p = (int *)malloc(n * sizeof(int) + 1);
        if (NULL == p) {
            printf("ERROR!\n");
            return 1;
        }

        for (i = 0; i < n; i++) {       // 获取要停留的楼层.
            scanf("%d", p + i);
        }
        TotalTime += p[0] * 6 + 5 * n;  // 停 n 次, 肯定会有 n*5 seconds

        for (i = 1; i < n; i++) {
            if (p[i] >= p[i - 1]) {     // 比较楼层大小.
                TotalTime += (p[i] - p[i - 1]) * 6;    // 向上
            } else {
                TotalTime += (p[i - 1] - p[i]) * 4;    // 向下
            }
        }
        printf("%d\n", TotalTime);

        TotalTime = 0;                  // 这个得清零, 进入下次计算
        free(p);                        // 不然只要运算次数多, 就会产生内存泄露.
    }

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值