hdu4352 XHXJ's LIS (数位dp)

Problem Description
#define xhxj (Xin Hang senior sister(学姐)) 
If you do not know xhxj, then carefully reading the entire description is very important.
As the strongest fighting force in UESTC, xhxj grew up in Jintang, a border town of Chengdu.
Like many god cattles, xhxj has a legendary life: 
2010.04, had not yet begun to learn the algorithm, xhxj won the second prize in the university contest. And in this fall, xhxj got one gold medal and one silver medal of regional contest. In the next year's summer, xhxj was invited to Beijing to attend the astar onsite. A few months later, xhxj got two gold medals and was also qualified for world's final. However, xhxj was defeated by zhymaoiing in the competition that determined who would go to the world's final(there is only one team for every university to send to the world's final) .Now, xhxj is much more stronger than ever,and she will go to the dreaming country to compete in TCO final.
As you see, xhxj always keeps a short hair(reasons unknown), so she looks like a boy( I will not tell you she is actually a lovely girl), wearing yellow T-shirt. When she is not talking, her round face feels very lovely, attracting others to touch her face gently。Unlike God Luo's, another UESTC god cattle who has cool and noble charm, xhxj is quite approachable, lively, clever. On the other hand,xhxj is very sensitive to the beautiful properties, "this problem has a very good properties",she always said that after ACing a very hard problem. She often helps in finding solutions, even though she is not good at the problems of that type.
Xhxj loves many games such as,Dota, ocg, mahjong, Starcraft 2, Diablo 3.etc,if you can beat her in any game above, you will get her admire and become a god cattle. She is very concerned with her younger schoolfellows, if she saw someone on a DOTA platform, she would say: "Why do not you go to improve your programming skill". When she receives sincere compliments from others, she would say modestly: "Please don’t flatter at me.(Please don't black)."As she will graduate after no more than one year, xhxj also wants to fall in love. However, the man in her dreams has not yet appeared, so she now prefers girls.
Another hobby of xhxj is yy(speculation) some magical problems to discover the special properties. For example, when she see a number, she would think whether the digits of a number are strictly increasing. If you consider the number as a string and can get a longest strictly increasing subsequence the length of which is equal to k, the power of this number is k.. It is very simple to determine a single number’s power, but is it also easy to solve this problem with the numbers within an interval? xhxj has a little tired,she want a god cattle to help her solve this problem,the problem is: Determine how many numbers have the power value k in [L,R] in O(1)time.
For the first one to solve this problem,xhxj will upgrade 20 favorability rate。
 

Input
First a integer T(T<=10000),then T lines follow, every line has three positive integer L,R,K.(
0<L<=R<2 63-1 and 1<=K<=10).
 

Output
For each query, print "Case #t: ans" in a line, in which t is the number of the test case starting from 1 and ans is the answer.
 

Sample Input
  
  
1 123 321 2
 

Sample Output
  
  
Case #1: 139

题意:求区间L到R之间的数中满足数位的最长严格递增序列的长度恰好为K的数的个数。

思路:用dp[i][state][j]表示到第i位状态为state,最长上升序列的长度为k的方案数。那么只要模拟nlogn写法的最长上升子序列的求法就行了。这里这里记忆化的时候一定要写成dp[pos][stata][k],表示前pos位,状态为state的,最长上升子序列长为k的方案数这里如果写成dp[pos][state][len]时会出错,因为有多组样例,每一组的k的值不同,那么不同k下得出的dp[pos][state][len]所对应的意义也不同。

#include<iostream>
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<math.h>
#include<vector>
#include<map>
#include<set>
#include<queue>
#include<stack>
#include<string>
#include<bitset>
#include<algorithm>
using namespace std;
typedef long long ll;
typedef long double ldb;
#define inf 99999999
#define pi acos(-1.0)
ll n,m;
int k;
int wei[30];
ll dp[25][1<<12][12]; //当前为第pos位,状态为state,最长长度为k的方案数
int getnum(int state)
{
    int tot=0;
    while(state){
        if(state&1)tot++;
        state>>=1;
    }
    return tot;
}
int getstate(int state,int x)
{
    int i,j;
    for(i=x;i<=9;i++){
        if((state&(1<<i))!=0 ){
            return (state^(1<<i))|(1<<x);
        }
    }
    return (state|(1<<x));
}

ll dfs(int pos,int state,int lim,int zero) //zero表示最高位是不是放下了,即是否任然是前导0
{
    int i,j;
    if(pos==0){
        if(getnum(state)==k){
            return 1;
        }
        return 0;
    }
    if(lim==0 && dp[pos][state][k]!=-1){ 
        return dp[pos][state][k];
    }
    int ed=lim?wei[pos]:9;
    ll ans=0;
    int state1,length1;
    for(i=0;i<=ed;i++){
        if(zero==1 && i==0){
            state1=0;
        }
        else{
            state1=getstate(state,i);
        }
        ans+=dfs(pos-1,state1,lim&&(i==ed),zero&&(i==0) );
    }
    if(lim==0){
        dp[pos][state][k]=ans; //这里记忆化的时候一定要写成dp[pos][stata][k],表示前pos位,状态为state,这样算下去最长上升子序列长为k的方案数
        //这里如果写成dp[pos][state][len]时会出错,因为有多组样例,每一组的k的值不同,那么不同k下得出的dp[pos][state][len]所对应的意义也不同。
    }
    return ans;
}
ll solve(ll x)
{
    ll xx=x;
    int i,j,tot=0;
    while(xx){
        wei[++tot]=xx%10;
        xx/=10;
    }
    return dfs(tot,0,1,1);

}
int main()
{
    int i,j,T,cas=0;
    memset(dp,-1,sizeof(dp));//这里要注意,dp的初始化放在最前面,这样可以少算重复的情况,节省时间
    scanf("%d",&T);
    while(T--)
    {
        scanf("%I64d%I64d%d",&m,&n,&k);
        cas++;
        printf("Case #%d: %I64d\n",cas,solve(n)-solve(m-1) );
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值