hdu 1312 Red and Black (dfs)

本题地址:点击打开链接

Red and Black

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 19852    Accepted Submission(s): 12060


Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.
 

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
 

Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
 

Sample Input
  
  
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
 

Sample Output
  
  
45 59 6 13
 

Source
 

Recommend
Eddy   |   We have carefully selected several similar problems for you:   1242  1253  1072  1258  1238 

本题题意:先输入 w 和 h 代表一个广场的宽 和高(长),w 和 h 均在20以内,再输入地图,其中

”.”——一表示黑色瓷砖

“#”——一表示红色的瓷砖

“@”——一表示人的当前位置(为黑色瓷砖)

人可以移动到四个相邻的瓷砖,但只能走黑色瓷砖,不能走红色瓷砖。求他能移动的所有瓷砖数量(包括当前位置的瓷砖)


解题思路:这个题是裸的深搜做法,不需要考虑其他。需要注意的是这个题的给的地图长和宽是相反的,也就是用数组保存地图时的行和列是相反的。


代码:

#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
int t;                         //可移动黑瓷砖的数量
int w,h;
int dir[4][2]={{-1,0},{0,-1},{1,0},{0,1}};          //可移动的四个方向
char mp[22][22];
void dfs(int x,int y)
{
    int nx,ny;
    for(int i=0;i<4;i++)
    {
        nx=x+dir[i][0];
        ny=y+dir[i][1];
        if(nx>=0&&ny>=0&&nx<h&&ny<w&&mp[nx][ny]=='.')//判断是否越界和能走(是黑瓷砖)
        {
            t++;                            //能走就说明可走数量加一
            mp[nx][ny]='#';                 //已经走过的地方置为红瓷砖,表示不能再走
            dfs(nx,ny);
        }
    }
}
int main()
{
    while(~scanf("%d%d",&w,&h)&&(w+h))
    {
        memset(mp,'#',sizeof(mp));
        for(int i=0;i<h;i++)
        {
            scanf("%s",mp[i]);          //建议使用这种输入方式,单个字符需要用getchar();吃掉行尾回车。
        }
        for(int i=0;i<h;i++)
        for(int j=0;j<w;j++)
        {
            if(mp[i][j]=='@')
            {
                t=1;
                dfs(i,j);
            }
        }
        printf("%d\n",t);
    }
    return 0;
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值