POJ1840(哈希)

14 篇文章 0 订阅
1 篇文章 0 订阅

大意

Description

Consider equations having the following form: 
a1x1 3+ a2x2 3+ a3x3 3+ a4x4 3+ a5x5 3=0 
The coefficients are given integers from the interval [-50,50]. 
It is consider a solution a system (x1, x2, x3, x4, x5) that verifies the equation, xi∈[-50,50], xi != 0, any i∈{1,2,3,4,5}. 

Determine how many solutions satisfy the given equation. 

Input

The only line of input contains the 5 coefficients a1, a2, a3, a4, a5, separated by blanks.

Output

The output will contain on the first line the number of the solutions for the given equation.

Sample Input

37 29 41 43 47

Sample Output

654

求方程解的个数。

分析;将原式变为

a1x1 3+ a2x2 3+ a3x3 3=- a4x4 3- a5x5 3

对左式枚举哈希处理,再计算右式查询。

代码

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#define maxn 1030307
int hashn[maxn], nextn[maxn];
int num[maxn];
using namespace std;
int main()
{
	int a, b, c, d, e;
	while (~scanf("%d%d%d%d%d", &a, &b, &c, &d, &e))
	{
		memset(hashn, -1, sizeof(hashn));
		int mm = 0;
		for (int i = -50; i <= 50; i++)
			if (i != 0)
				for (int j = -50; j <= 50; j++)
					if (j != 0)
						for (int k = -50; k <= 50; k++)
							if (k != 0)
							{
								int t = a*i*i*i + b*j*j*j + c*k*k*k;
								num[mm] = t;
								int key = t%maxn;
								key = (key + maxn) % maxn;
								nextn[mm] = hashn[key];
								hashn[key] = mm;
								mm++;
							}
		int sum = 0;
		for (int i = -50; i <= 50; i++)
			if (i != 0)
				for (int j = -50; j <= 50; j++)
					if (j != 0)
					{
						int t = -e*i*i*i - d*j*j*j;
						int key = t%maxn;
						key = (key + maxn) % maxn;
						int m = hashn[key];
						while (m != -1)
						{
							if (t == num[m])
								sum++;
							m = nextn[m];
						}
					}
		printf("%d\n", sum);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值