状态压缩dp入门 第一题 POJ 3254 Corn Fields

Corn Fields
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 6460 Accepted: 3436

Description

Farmer John has purchased a lush new rectangular pasture composed of M by N (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares are infertile and can't be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice as to which squares to plant.

Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways he can choose the squares to plant.

Input

Line 1: Two space-separated integers:  M and  N 
Lines 2.. M+1: Line  i+1 describes row  i of the pasture with  N space-separated integers indicating whether a square is fertile (1 for fertile, 0 for infertile)

Output

Line 1: One integer: the number of ways that FJ can choose the squares modulo 100,000,000.

Sample Input

2 3
1 1 1
0 1 0

Sample Output

9

Hint

Number the squares as follows:
1 2 3
  4  

There are four ways to plant only on one squares (1, 2, 3, or 4), three ways to plant on two squares (13, 14, or 34), 1 way to plant on three squares (134), and one way to plant on no squares. 4+3+1+1=9.


题意:农夫FJ有一块n行m列的矩形土地, 有的土地是肥沃的,可以在这些土地上放牛(用1表示),有的土地不能放牛(用0表示),而且相邻的可以放牛的格子不能同时有牛,问FJ一共有多少种放牛的方案(一头牛都不放也是一种方案)。

分析:以样例为例,我们可以一行一行的考虑。假如对于每一行,用1表示放牛,0表示不放牛,

第一行的状态为:000001010011(舍弃) 100101110(舍弃)111(舍弃)

符合题意的状态只有5个,所以第一行有5种方案。

第二行的状态为:000010

但是第二行中的010和第一行中的010冲突,所以如果第二行状态为010时,共有4种方案;状态为000时,有5种方案,所以一共有4+5=9种方案。

分析完我们会发现,对于每一行,都可以一个01串来表示这一行的状态,而这个状态可以用一个十进制整数来代替,也就是说,把这个状态压缩成了一个十进制整数,所以称为是状态压缩。

本题中,dp[i][j] 就表示第i行状态为j时的方案数。

状态压缩dp中最常见的就是位运算,因为位运算可以很方便的判断当前状态是否合法。例如本题中判断第i行是不是有两块相邻的土地同时都有牛,假设当前状态为X,那么只需要判断X&(X>>1)或者X&(X<<1)的结果是不是0,如果是0,说明没有相邻的,否则就说明有相邻的。

#include<stdio.h>
#include<string.h>
#include<vector>
using namespace std;
#define mod 100000000
const int N = 1<<12 + 4;
int dp[15][N], Map[15][15];
int n, m;
vector<int> vec[14];
int Pow(int a, int x) //2的X次方
{
    int s = 1;
    for(int i = 1; i <= x; i++)
        s <<= 1;
    return s;
}
int fun(int x) //求第X行的土地状态,0表示可以放牛,1表示不能放牛
{
    int s = 0;
    for(int i = 1; i <= m; i++)
        s += (!Map[x][i]) * Pow(2, m-i);
    return s;
}
int main()
{
    int i, j;
    while(~scanf("%d%d",&n,&m))
    {
        memset(dp, 0, sizeof(dp));
        memset(vec, 0, sizeof(vec));
        for(i = 1; i <= n; i++)
            for(j = 1; j <= m; j++)
                scanf("%d",&Map[i][j]);
        vec[0].push_back(0);
        int k = 1<<m;
        for(i = 0; i < k; i++)
            dp[0][i] = 1;
        for(i = 1; i <= n; i++)
        {
            int tmp = fun(i); //当前行的状态
            for(j = 0; j < k; j++)
            {
                if(j & (j>>1)) continue; //j的二进制表示中有两个相邻的1
                if(j & tmp) continue; //排除在当前行不符合条件的
                vec[i].push_back(j);
            }
            for(j = 0; j < vec[i].size(); j++) //排除和上一行冲突的
            {
                int u = vec[i][j];
                for(int z = 0; z < vec[i-1].size(); z++)
                {
                    int v = vec[i-1][z];
                    if(u & v) continue;
                    dp[i][u] = (dp[i][u] + dp[i-1][v]) % mod;
                }
            }
        }
        int ans = 0;
        for(i = 0; i < k; i++)
            ans = (ans + dp[n][i]) % mod;
        printf("%d\n",ans);
    }
    return 0;
}


代码二:

/*   dp[i][j] 表示第i行状态为j时的合法状态数量 */

#include <cstdio>
#include <cstring>
const int N = 13;
#define mod 100000000
int dp[N][1<<N];
int beg[N];

bool checkA(int x) {  //判断本行是否合法
    return !(x & (x >> 1));
}

bool checkB(int a, int b) { //判断和上一行是否冲突
    return !(a & b);
}

int main() {
    int n, m, t;
    while(~scanf("%d%d", &n, &m)) {
        memset(dp, 0, sizeof(dp));
        memset(beg, 0, sizeof(beg));
        for(int i = 0; i < n; i++) {
            for(int j = 0; j < m; j++) {
                scanf("%d", &t);
                if(t) beg[i] = beg[i] | (1 << j);
            }
        }

        for(int i = 0; i < (1<<m); i++) //求出第一行的合法状态数目
            if((beg[0]|i) == beg[0] && checkA(i))
                dp[0][i] = 1; 
                
        for(int i = 1; i < n; i++) {
            for(int j = 0; j < (1<<m); j++) {  //枚举本行状态
                if(((beg[i]|j) == beg[i]) && checkA(j)) {
                    for(int k = 0; k < (1<<m); k++) { //枚举上一行的状态
                        if(checkB(j, k)) //根据上一行递推出本行
                            dp[i][j] = (dp[i][j] + dp[i-1][k]) % mod;
                    }
                }
            }
        }
        
        int ans = 0;
        for(int i = 0; i < (1<<m); i++)
            ans = (ans + dp[n-1][i]) % mod;
        printf("%d\n", ans);
    }
    return 0;
}


  • 2
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值