Installation error: INSTALL_FAILED_CONFLICTING_PROVIDER

原创 2012年03月26日 17:29:15
[2012-03-20 13:05:23 - FuyaoTest] Installation error: INSTALL_FAILED_CONFLICTING_PROVIDER
[2012-03-20 13:05:23 - FuyaoTest] Please check logcat output for more details.

[2012-03-20 13:05:23 - FuyaoTest] Launch canceled!


出现这个错误的原因:FuyaoTest项目中的Provider与已安装项目中的Provider相同。

解决方法:

       修改当前项目中的AndroidManifest.xml中的

<provider android:name="FuyaoTestProvider" 
            android:authorities="com.fuyao.provider.FuyaoProvider">

</provider>

即将android:authorities的值修改为别的就可以了。


参考出处:http://choujinoffice.blog.163.com/blog/static/17082405120109267538763/


版权声明:本文为博主原创文章,未经博主允许不得转载。

相关文章推荐

Installation error: INSTALL_FAILED_CONFLICTING_PROVIDER

Installation error: INSTALL_FAILED_CONFLICTING_PROVIDER

INSTALL FAILED CONFLICTING PROVIDER问题完美解决方案

在安装Android应用时出现INSTALL FAILED CONFLICTING PROVIDER问题,是不是感觉很抓狂呢,下面就跟大家分享一下出现这个问题的原因及解决方案。问题原因在Android...

Android解决INSTALL_FAILED_CONFLICTING_PROVIDER错误的方法

在开发Android应用时,有时在安装应用时,会提示 INSTALL_FAILED_CONFLICTING_PROVIDER 错误,如下图 这是因为你定义的provider的authority与...

关于Installation error: INSTALL_FAILED_INSUFFICIENT_STORAGE的报错的最有效的解决方法

好久没有在真的Android机子上运行程序了,

Installation error: INSTALL_FAILED_UPDATE_INCOMPATIBLE

1、发生原因 使用Eclipse在魅蓝(Android5.1)上安装,在Console中直接报错 2、解决过程 不想看过程的,可以直接看小结 既然Eclipse直接装不行,想到改用命令adb inst...

android 应用未安装 及 Installation error: INSTALL_FAILED_UPDATE_INCOMPATIBLE

记录一个问题,尚未完全解决,但也算是一个暂时的解决办法,项目时间很紧张,就先这样吧。 以前有碰到过应用调试的程序可以安装运行,但是打包之后的apk可以安装但是无法运行的问题,当时根据自己这个版本针对...

shared user id / Installation error: INSTALL_FAILED_SHARED_USER_INCOMPATIBLE .

在windows平台通过eclipse编译android源码中,如果编译Settings或者android manifest XML中 shared user id 包含android.uid.sha...

android错误:Installation error: INSTALL_FAILED_VERSION_DOWNGRADE

这个错误是  android:versionCode的值太小 解决方法是改变这个值  为了快速测试  我一直是立马改成200 绝对没有问题

shared user id / Installation error: INSTALL_FAILED_SHARED_USER_INCOMPATIBLE

-----在windows平台通过eclipse编译android源码中,如果编译Settings或者android manifest XML中 shared user id 包含android.ui...

关于Installation error: INSTALL_FAILED_NO_MATCHING_ABIS的解决方法

遇到过好几次这种错误提示,工程代码没有任何错误,但是连安装都安装不上模拟器,console控制台就报出上面的错误:[2015-11-25 15:15:37 - Em4.x] Installation ...
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:深度学习:神经网络中的前向传播和反向传播算法推导
举报原因:
原因补充:

(最多只允许输入30个字)