关闭

使用composer安装yii遇到的问题汇总

361人阅读 评论(0) 收藏 举报
分类:

(1)安装过程遇到:

Your requirements could not be resolved to an installable set of packages.

 Problem 1

    - yiisoft/yii2 2.0.8 requires bower-asset/jquery 2.2.*@stable | 2.1.*@stable | 1.11.*@stable -> no matching package found.

    - yiisoft/yii2 2.0.7 requires bower-asset/jquery 2.2.*@stable | 2.1.*@stable | 1.11.*@stable -> no matching package found.

    - yiisoft/yii2 2.0.6 requires bower-asset/jquery 2.1.*@stable | 1.11.*@stable -> no matching package found.

    - yiisoft/yii2 2.0.5 requires bower-asset/jquery 2.1.*@stable | 1.11.*@stable -> no matching package found.

    - Installation request for yiisoft/yii2 >=2.0.5 -> satisfiable by yiisoft/yii2[2.0.5, 2.0.6, 2.0.7, 2.0.8].


Potential causes:

 - A typo in the package name

 - The package is not available in a stable-enough version according to your minimum-stability setting

   see <https://getcomposer.org/doc/04-schema.md#minimum-stability> for more details.


Read <https://getcomposer.org/doc/articles/troubleshooting.md> for further common problems.


网上很多指导方案都是按照yii 官方的
composerglobalrequire"fxp/composer-asset-plugin:~1.0.0"
来选择加载插件,但是依然不能通过,不清楚,是不是mac的原因,插件版本难道不对,在更换了多次,清除缓存、删除路径下代码等工作之后,我在“1.0.0”的位置,尝试了1.1.1。结果证实,是可以的。(composer 才刚刚接触,后续的东西,要再仔细的研究,嘿嘿,不妄我折腾这么久!)



0
0

查看评论
* 以上用户言论只代表其个人观点,不代表CSDN网站的观点或立场
    个人资料
    • 访问:4039次
    • 积分:135
    • 等级:
    • 排名:千里之外
    • 原创:10篇
    • 转载:1篇
    • 译文:0篇
    • 评论:0条