数据结构与算法问题 北大oj 2075(最小生成树)

Tangled in Cables
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 5943 Accepted: 2342

Description

You are the owner of SmallCableCo and have purchased the franchise rights for a small town. Unfortunately, you lack enough funds to start your business properly and are relying on parts you have found in an old warehouse you bought. Among your finds is a single spool of cable and a lot of connectors. You want to figure out whether you have enough cable to connect every house in town. You have a map of town with the distances for all the paths you may use to run your cable between the houses. You want to calculate the shortest length of cable you must have to connect all of the houses together.

Input

Only one town will be given in an input. 
  • The first line gives the length of cable on the spool as a real number. 
  • The second line contains the number of houses, N 
  • The next N lines give the name of each house's owner. Each name consists of up to 20 characters {a–z,A–Z,0–9} and contains no whitespace or punctuation. 
  • Next line: M, number of paths between houses 
  • next M lines in the form

< house name A > < house name B > < distance > 
Where the two house names match two different names in the list above and the distance is a positive real number. There will not be two paths between the same pair of houses.

Output

The output will consist of a single line. If there is not enough cable to connect all of the houses in the town, output 
Not enough cable 
If there is enough cable, then output 
Need < X > miles of cable 
Print X to the nearest tenth of a mile (0.1).

Sample Input

100.0
4
Jones
Smiths
Howards
Wangs
5
Jones Smiths 2.0
Jones Howards 4.2
Jones Wangs 6.7
Howards Wangs 4.0
Smiths Wangs 10.0

Sample Output

Need 10.2 miles of cable.


     因为需要输入字符,我用了STL中的map映射,将地址名字符串映射为1,2,3....n.

代码:

#include <iostream>
#include <string>
#include <map>
using namespace std;
const int IN = 65535;
typedef struct graph
{
	string vex[200];
	double adj[200][200];
	int numvex, numedge;
}graph;

double num;
void create(graph *g)
{
	int i, j,x1,x2;
	string s1, s2;
	double w;//权值
	map<string,int> s;
	cin >> num;
	cin >> g->numvex;
	for (i = 0; i < g->numvex; i++)
	{
		cin >> g->vex[i];
		s[g->vex[i]] = i;
	}
	cin >> g->numedge;
	for (i = 0; i < g->numedge; i++)
		for (j = 0; j < g->numedge; j++)
			g->adj[i][j] = IN;

	for (j = 0; j < g->numedge; j++)
	{
		cin >> s1 >> s2 >> w;
		x1 = s[s1];
		x2 = s[s2];
		g->adj[x1][x2] = w;
		g->adj[x2][x1] = g->adj[x1][x2];
	}

}

void prim(graph *g)
{
	int i, j, k;
	double bowcost[200];
	double min, num1 = 0;
	int adjvex[200];
	bowcost[0] = 0;
	adjvex[0] = 0;
	for (i = 1; i < g->numvex; i++)
	{
		adjvex[i] = 0;
		bowcost[i] = g->adj[0][i];
	}
	for (i = 1; i < g->numvex; i++)
	{
		min = IN;
		j = 1;
		while (j < g->numvex)
		{
			if (bowcost[j] != 0 && bowcost[j] < min)
			{
				min = bowcost[j];
				k = j;
			}
			j++;
			
		}
		num1 += min; 
		
		bowcost[k] = 0;
		for (j = 1; j < g->numvex; j++)
		{
			if (g->adj[k][j] < bowcost[j]&&bowcost[j] != 0)
			{
				bowcost[j] = g->adj[k][j];
				adjvex[j] = k;
			}
		}

	}
	cout << "Need" << num << "miles of cable" << endl;
}

int main()
{
	graph *g = new graph;
	create(g);
	prim(g);
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值