hdu 2844 Coins 多重背包模板题 ,二进制优化。据说是楼教主的男人八题之一

154 篇文章 1 订阅
26 篇文章 0 订阅

Coins

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8052    Accepted Submission(s): 3291


Problem Description
Whuacmers use coins.They have coins of value A1,A2,A3...An Silverland dollar. One day Hibix opened purse and found there were some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch.

You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins.
 

Input
The input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci ≤ 1000). The last test case is followed by two zeros.
 

Output
For each test case output the answer on a single line.
 

Sample Input
  
  
3 10 1 2 4 2 1 1 2 5 1 4 2 1 0 0
 

Sample Output
  
  
8 4
 
最近一直在做DP的题目,,都是一些模板题,,现在已成了背包九讲作者的死忠了。如果我是女的,,我一定要嫁给写出背包九讲的男人o(╯□╰)o

先说一下二进制优化的原理:
1、2、4可以组合出所有小于8的数;
1、2、4、8可以组合出所有小于16的数;
1、2、4、8、16可以组合出所有小于32的数;

我的代码:

#include <stdio.h>
#include <string.h>
#define M 100100 
#define N 110

int a[N] , c[N] , dp[M] ;

void zeroOnePack(int value , int m)
{
	for(int i = m ; i >= value ; --i)
	{
		if(dp[i]<dp[i-value]+value)
		{
			dp[i] = dp[i-value]+value ;
		}
	}
}

void completePack(int value , int m)
{
	for(int i = value ; i <= m ; ++i)
	{
		if(dp[i]<dp[i-value]+value)
		{
			dp[i] = dp[i-value]+value ;
		}
	}
}

void multiplePack(int value , int count , int total)
{
	if(value*count>total)
	{
		completePack(value , total) ;
	}
	else
	{
		int k = 1 ;
		while(k<=count)
		{
			zeroOnePack(k*value , total) ;
			count -= k ;
			k = 2*k ;
		}
		zeroOnePack(count*value,total) ;
	}
}

int main()
{
	int n ,m ;
	while(~scanf("%d%d",&n,&m) && (n||m))
	{
		for(int i = 0 ; i < n ; ++i)
		{
			scanf("%d",&a[i]);
		}
		for(int i = 0 ; i < n ; ++i)
		{
			scanf("%d",&c[i]);
		}
		
		memset(dp,0,sizeof(dp)) ;
		
		for(int i = 0 ; i < n ; ++i)
		{
			multiplePack(a[i],c[i],m);
		}
		int ans = 0 ;
		for(int i = 1 ; i <= m ; ++i)
		{
			if(i == dp[i])
			{
				++ans ;
			}
		}
		printf("%d\n",ans) ;
	}
	return 0 ;
}




  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值