HDU 5883 The Best Path 2016青岛网赛

The Best Path
Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 116    Accepted Submission(s): 42


Problem Description
Alice is planning her travel route in a beautiful valley. In this valley, there are N lakes, and M rivers linking these lakes. Alice wants to start her trip from one lake, and enjoys the landscape by boat. That means she need to set up a path which go through every river exactly once. In addition, Alice has a specific number (a1,a2,...,an) for each lake. If the path she finds is P0→P1→...→Pt, the lucky number of this trip would be aP0XORaP1XOR...XORaPt. She want to make this number as large as possible. Can you help her?


Input
The first line of input contains an integer t, the number of test cases. t test cases follow.

For each test case, in the first line there are two positive integers N (N≤100000) and M (M≤500000), as described above. The i-th line of the next N lines contains an integer ai(∀i,0≤ai≤10000) representing the number of the i-th lake.

The i-th line of the next M lines contains two integers ui and vi representing the i-th river between the ui-th lake and vi-th lake. It is possible that ui=vi.


Output
For each test cases, output the largest lucky number. If it dose not have any path, output "Impossible".


Sample Input

2
3 2
3
4
5
1 2
2 3
4 3
1
2
3
4
1 2
2 3
2 4



Sample Output

2
Impossible

不难发现 (a^b)^c==a^(b^c)
对任意a,b,c,d 以任意顺序全部异或起来 值都是一样的(满足结合律)
所以问题简化为 求解路径中每个点被经过了几次
每条边都要走一遍 其实就是一笔画问题 欧拉回路
可以参考南阳OJ的一笔画 http://blog.csdn.net/LuRiCheng/article/details/52415262


①因为图中可能有孤立的点 也可能不联通
显然 孤立点没连接的边 度为0 只要并查集统计度>0的集合有几个 集合数>1 Impossible
①每个点的入度==出度 进了i点 就必然要从i点出来 (排除掉起点和终点可能入度!=出度 这种情况特判)

考虑起点和终点入度!=出度  即有2个点是奇数度的
点被经过的次数=度数/2              //度数%2==0
点被经过的次数=(度数+1)/2          //度数%2==1
考虑起点终点入度==出度   即所有点都是奇数度
这种情况只有从起点就是终点才会发生 而且起点可能是连通集合里的任何点
所以
点被经过次数=度数/2            //不是起点
点被经过次数=度数/2+1           //起点
穷举一遍起点就可以了

#include<iostream>
#include<stdlib.h>
#include<stdio.h>
#include<string>
#include<vector>
#include<deque>
#include<queue>
#include<algorithm>
#include<set>
#include<map>
#include<stack>
#include<time.h>
#include<math.h>
#include<list>
#include<cstring>
#include<fstream>
//#include<memory.h>
using namespace std;
#define ll long long
#define ull unsigned long long
#define pii pair<int,int>
#define INF 1000000007
#define pll pair<ll,ll>
#define pid pair<int,double>

const int N=100000+5;
const int M=500000+5;

int par[N];//并查集
int e[N];//e[i]记录点i的度
int a[N];

inline int find(int x){//查找
    return x==par[x]?x:par[x]=find(par[x]);
}

inline void unite(int f,int t){//合并
    par[find(f)]=find(t);
}

int main()
{
    //freopen("/home/lu/文档/r.txt","r",stdin);
    //freopen("/home/lu/文档/w.txt","w",stdout);

    int t;
    scanf("%d",&t);
    while(t--){
        int n,m;
        scanf("%d%d",&n,&m);
        for(int i=1;i<n+1;++i){
            par[i]=i;//初始化并查集
            e[i]=0;
            scanf("%d",a+i);
        }
        int u,v;
        while(m--){
            scanf("%d%d",&u,&v);
            ++e[u];
            ++e[v];
            unite(u,v);//合并a,b点
        }
        int par_num=0;//连通的集合个数
        int sim_num=0;//奇数度的个数
        for(int i=1;i<=n;++i){
            par_num+=(par[i]==i&&e[i]>0);
            sim_num+=e[i]&1;
        }
        if((par_num==1)&&(sim_num==2||sim_num==0)){
            int ans=a[1];
            e[1]-=2;
            while(e[1]>0){
                ans^=a[1];
                e[1]-=2;
            }
            for(int i=2;i<=n;++i)
                while(e[i]>0){
                    ans^=a[i];
                    e[i]-=2;
                }
            if(sim_num==0){
                int t=ans;
                for(int i=1;i<=n;++i)
                    ans=max(t^a[i],ans);
            }
            printf("%d\n",ans);
        }
        else{
            printf("Impossible\n");
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值