poj 2184 - Cow Exhibition (01背包) 解题报告


Cow Exhibition
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10279 Accepted: 4016

Description

"Fat and docile, big and dumb, they look so stupid, they aren't much 
fun..." 
- Cows with Guns by Dana Lyons 

The cows want to prove to the public that they are both smart and fun. In order to do this, Bessie has organized an exhibition that will be put on by the cows. She has given each of the N (1 <= N <= 100) cows a thorough interview and determined two values for each cow: the smartness Si (-1000 <= Si <= 1000) of the cow and the funness Fi (-1000 <= Fi <= 1000) of the cow. 

Bessie must choose which cows she wants to bring to her exhibition. She believes that the total smartness TS of the group is the sum of the Si's and, likewise, the total funness TF of the group is the sum of the Fi's. Bessie wants to maximize the sum of TS and TF, but she also wants both of these values to be non-negative (since she must also show that the cows are well-rounded; a negative TS or TF would ruin this). Help Bessie maximize the sum of TS and TF without letting either of these values become negative. 

Input

* Line 1: A single integer N, the number of cows 

* Lines 2..N+1: Two space-separated integers Si and Fi, respectively the smartness and funness for each cow. 

Output

* Line 1: One integer: the optimal sum of TS and TF such that both TS and TF are non-negative. If no subset of the cows has non-negative TS and non- negative TF, print 0. 

Sample Input

5
-5 7
8 -6
6 -3
2 1
-8 -5

Sample Output

8

Hint

OUTPUT DETAILS: 

Bessie chooses cows 1, 3, and 4, giving values of TS = -5+6+2 = 3 and TF 
= 7-3+1 = 5, so 3+5 = 8. Note that adding cow 2 would improve the value 
of TS+TF to 10, but the new value of TF would be negative, so it is not 
allowed. 

题意:

给你n头奶牛,每头奶牛有个聪明值si和一个有趣值fi。问你从其中取出若干头奶牛,使得这些奶牛的si+fi最大的同时si的总和>=0,fi的总和也>=0。输出最大值。

题解:

这是题01背包,思路是用dp[s]求出当聪明值为s时最大的有趣值。

递推方程:dp[s+j]=max(dp[s+j],dp[j]+t)。

为了处理方便,我们将原点定在100000处,使得dp[s+j]中的s+j始终为正。

参考代码:

#include<stdio.h>
#define inf 999999999
#define pos 100000
#define M 200005
#define max(a,b) a>b?a:b
int dp[M];
int main()
{
	int n,s,t,max1,min1,ans;
	while(~scanf("%d",&n))
	{
		max1=min1=pos;
		for(int i=1;i<M;i++)
		    dp[i]=-inf;
        dp[pos]=0;
        for(int i=1;i<=n;i++)
        {
        	scanf("%d%d",&s,&t);
			if(s>=0)
			{
				for(int j=max1;j>=min1;j--)
				{
					dp[j+s]=max(dp[j+s],dp[j]+t);
				}
				max1+=s;
			}
			else 
			{
				for(int j=min1;j<=max1;j++)
				{
					dp[j+s]=max(dp[j+s],dp[j]+t);
				}
				min1+=s;
			}
			
        }
        ans=0;
		for(int i=pos;i<=max1;i++)
		{
		    if(dp[i]>=0)
		        ans=max(ans,dp[i]+i-pos);
				
		}
		printf("%d\n",ans);
	}
	return 0;
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值