hdu 1798 - Tell me the area(求两圆相交面积) 解题报告

Tell me the area

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2113    Accepted Submission(s): 642


Problem Description
    There are two circles in the plane (shown in the below picture), there is a common area between the two circles. The problem is easy that you just tell me the common area.

 

Input
There are many cases. In each case, there are two lines. Each line has three numbers: the coordinates (X and Y) of the centre of a circle, and the radius of the circle.
 

Output
For each case, you just print the common area which is rounded to three digits after the decimal point. For more details, just look at the sample.
 

Sample Input
  
  
0 0 2 2 2 1
 

Sample Output
  
  
0.108
 

参考代码:

#include<stdio.h>
#include<math.h>
#define PI acos(-1.0)
int main(){
    double a1,b1,r1,a2,b2,r2,d;
    double A1,A2,s1,s2,s;                
    while(~scanf("%lf%lf%lf%lf%lf%lf",&a1,&b1,&r1,&a2,&b2,&r2))
    {
        d=sqrt((a2-a1)*(a2-a1)+(b2-b1)*(b2-b1)); //求圆心距
        if(d>=r1+r2)
	        printf("0.000\n");     //两圆相离或相外切
        else if(d<=fabs(r1-r2))//内切或内含 
        {  
            if(r1>r2)    
			    printf("%0.3lf\n",PI*r2*r2);
            else   
			    printf("%0.3lf\n",PI*r1*r1);
        }
        else{
   	
            A1=2*acos((d*d+r1*r1-r2*r2)/(2*d*r1)); //用余弦定理求以圆心为顶点与两圆交点连线的角
            A2=2*acos((d*d+r2*r2-r1*r1)/(2*d*r2));
            s1=0.5*r1*r1*sin(A1)+0.5*r2*r2*sin(A2);
            s2=A1/2*r1*r1+A2/2*r2*r2;
            s=s2-s1;
            printf("%0.3lf\n",s);
        }
    }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值