POJ-1012 Joseph-约瑟夫问题好人坏人

Joseph
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 50354 Accepted: 19143

Description

The Joseph's problem is notoriously known. For those who are not familiar with the original problem: from among n people, numbered 1, 2, . . ., n, standing in circle every mth is going to be executed and only the life of the last remaining person will be saved. Joseph was smart enough to choose the position of the last remaining person, thus saving his life to give us the message about the incident. For example when n = 6 and m = 5 then the people will be executed in the order 5, 4, 6, 2, 3 and 1 will be saved.

Suppose that there are k good guys and k bad guys. In the circle the first k are good guys and the last k bad guys. You have to determine such minimal m that all the bad guys will be executed before the first good guy.

Input

The input file consists of separate lines containing k. The last line in the input file contains 0. You can suppose that 0 < k < 14.

Output

The output file will consist of separate lines containing m corresponding to k in the input file.

Sample Input

3
4
0

Sample Output

5
30

Source

Central Europe 1995

#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;

int main()
{
    int k,i,j,m,n,r[15],a[30];
    memset(r,0,sizeof(r));
    for(i=1; i<14; ++i)//人数范围是1-14
    {
        memset(a,0,sizeof(a));
        n=2*i;
        m=1;//先m=1开始尝试
        for(j=1; j<=i; j++)
        {   /*运用公式j=(j+m-1)%(n-i)
            (这个公式求出的只是在新的排列下出现的位置),
            推导出下一个出现的元素在第几号位置,*/
            a[j]=(a[j-1]+m-1)%(n-j+1);
            if(a[j]<i)//1-k是好人,不能杀
            {
                j=0;
                ++m;//穷举m一次次尝试
            }
        }
        r[i]=m;
    }
    while(cin>>k,k)
        cout<<r[k]<<endl;
    return 0;
}


  • 2
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值