POJ 3176-Cow Bowling/POJ 1163-The Triangle(简单DP-数塔)

Cow Bowling
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 18487 Accepted: 12308

Description

The cows don't use actual bowling balls when they go bowling. They each take a number (in the range 0..99), though, and line up in a standard bowling-pin-like triangle like this: 

          7



        3   8



      8   1   0



    2   7   4   4



  4   5   2   6   5
Then the other cows traverse the triangle starting from its tip and moving "down" to one of the two diagonally adjacent cows until the "bottom" row is reached. The cow's score is the sum of the numbers of the cows visited along the way. The cow with the highest score wins that frame. 

Given a triangle with N (1 <= N <= 350) rows, determine the highest possible sum achievable.

Input

Line 1: A single integer, N 

Lines 2..N+1: Line i+1 contains i space-separated integers that represent row i of the triangle.

Output

Line 1: The largest sum achievable using the traversal rules

Sample Input

5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

Sample Output

30

Hint

Explanation of the sample: 

          7

         *

        3   8

       *

      8   1   0

       *

    2   7   4   4

       *

  4   5   2   6   5
The highest score is achievable by traversing the cows as shown above.

Source


题目意思:

N行的数塔,从最上面一行的一个数开始,每次只能选择其下一行的左右对称两个数的其中一个,将数相加,计算走到最后一行的最大和。


解题思路:

简单DP,方程是dp[i][j]=a[i][j]+max(dp[i+1][j],dp[i+1][j+1]);从最后一行向上计算。


#include<iostream>
#include<cstdio>
#include<iomanip>
#include<cmath>
#include<cstdlib>
#include<cstring>
#include<map>
#include<algorithm>
#include<vector>
#include<queue>
using namespace std;
#define INF 0x3f3f3f3f
#define MAXN 400
int a[MAXN][MAXN],dp[MAXN][MAXN];//dp[i][j]表示第i行 第j列上的最大值
int main()
{
#ifdef ONLINE_JUDGE
#else
    freopen("F:/cb/read.txt","r",stdin);
    //freopen("F:/cb/out.txt","w",stdout);
#endif
    ios::sync_with_stdio(false);
    cin.tie(0);
    int n;
    while(cin>>n)
    {
        for(int i=0; i<n; ++i)
            for(int j=0; j<=i; ++j)
                cin>>a[i][j];//输入
        memset(dp,0,sizeof(dp));//初始化
        for(int i=0; i<n; ++i)
            for(int j=0; j<=i; ++j)
                dp[i][j]=a[i][j]+max(dp[i+1][j],dp[i+1][j+1]);//复制a数组到dp
        for(int i=n-1; i>=0; --i)//从最后一行向上计算
            for(int j=0; j<=i; ++j)
                dp[i][j]=a[i][j]+max(dp[i+1][j],dp[i+1][j+1]);
        /*for(int i=0; i<n; ++i)
        {
            for(int j=0; j<=i; ++j)
                cout<<dp[i][j]<<" ";
            cout<<endl;
        }*/
        cout<<dp[0][0]<<endl;
    }
    return 0;
}
/*
5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5
*/


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值