PAT甲级-1009. Product of Polynomials (25)一元多项式相乘

1009. Product of Polynomials (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

This time, you are supposed to find A*B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < ... < N2 < N1 <=1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 3 3.6 2 6.0 1 1.6

给出两个多项式的K个非零项的指数和系数,输出两式相乘后的非零项个数及各项的指数和系数。

系数结果保留一位小数。

#include<bits/stdc++.h>
using namespace std;
#define INF 0xfffffff
#define MAXN 10010
int main()
{
#ifdef ONLINE_JUDGE
#else
    freopen("F:/cb/read.txt","r",stdin);
//freopen("F:/cb/out.txt","w",stdout);
#endif
    ios::sync_with_stdio(false);
    cin.tie(0);
    int n;
    double a[MAXN],b[MAXN],ans[MAXN];//相乘数组开大
    memset(a,0,sizeof(a));
    memset(b,0,sizeof(b));
    memset(ans,0,sizeof(ans));
    cin>>n;
    int ma=0,mb=0,cnt=0;
    while(n--)
    {
        int x;
        double y;
        cin>>x>>y;
        ma=max(ma,x);
        a[x]=y;
    }
    cin>>n;
    while(n--)
    {
        int x;
        double y;
        cin>>x>>y;
        mb=max(mb,x);
        b[x]=y;
    }
    for(int i=0; i<=ma; ++i)
        for(int j=0; j<=mb; ++j)
            ans[i+j]+=(a[i]*b[j]);
    int pos=ma+mb;
    for(int i=ma+mb; i>=0; --i)
        if(ans[i]!=0) ++cnt,pos=min(pos,i);
    cout<<cnt<<" ";
    for(int i=ma+mb; i>pos; --i)
        if(ans[i]!=0) cout<<i<<" "<<setiosflags(ios::fixed)<<setprecision(1)<<ans[i]<<" ";
    cout<<pos<<" "<<setiosflags(ios::fixed)<<setprecision(1)<<ans[pos]<<endl;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值