poj 2377 最小生成树(kruskal算法)

Bad Cowtractors
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 12090 Accepted: 5022
Description

Bessie has been hired to build a cheap internet network among Farmer John’s N (2 <= N <= 1,000) barns that are conveniently numbered 1..N. FJ has already done some surveying, and found M (1 <= M <= 20,000) possible connection routes between pairs of barns. Each possible connection route has an associated cost C (1 <= C <= 100,000). Farmer John wants to spend the least amount on connecting the network; he doesn’t even want to pay Bessie.

Realizing Farmer John will not pay her, Bessie decides to do the worst job possible. She must decide on a set of connections to install so that (i) the total cost of these connections is as large as possible, (ii) all the barns are connected together (so that it is possible to reach any barn from any other barn via a path of installed connections), and (iii) so that there are no cycles among the connections (which Farmer John would easily be able to detect). Conditions (ii) and (iii) ensure that the final set of connections will look like a “tree”.
Input

  • Line 1: Two space-separated integers: N and M

  • Lines 2..M+1: Each line contains three space-separated integers A, B, and C that describe a connection route between barns A and B of cost C.
    Output

  • Line 1: A single integer, containing the price of the most expensive tree connecting all the barns. If it is not possible to connect all the barns, output -1.
    Sample Input

5 8
1 2 3
1 3 7
2 3 10
2 4 4
2 5 8
3 4 6
3 5 2
4 5 17
Sample Output

42
Hint

OUTPUT DETAILS:

The most expensive tree has cost 17 + 8 + 10 + 7 = 42. It uses the following connections: 4 to 5, 2 to 5, 2 to 3, and 1 to 3.

对于一个生成树,如果边上有权值,那么使得权边和最小的生成树叫做最小生成树。

想法:题目意思是要有一颗生成树,而且这棵树不能有圈,而最小生成树,正好符合这个条件(顶点数为N,边数为N-1)。要求边权和的最大值,只需把重定义sort的小于运算符,即可。

#include <iostream>
#include <sstream>
#include <ios>
#include <iomanip>
#include <functional>
#include <algorithm>
#include <vector>
#include <string>
#include <list>
#include <queue>
#include <deque>
#include <stack>
#include <set>
#include <map>
#include <cstdio>
#include <cstdlib>
#include <cmath>
#include <cstring>
#include <climits>
#include <cctype>
using namespace std;
int par[1100];
int r[1100];
int n,m,cnt;
void init(int n)
{
    for (int i = 1; i<=n; i++) {
        par[i] = i;
        r[i] = 0;
    }
}
int find(int x)
{
    if (par[x] == x) {
        return x;
    }
    else return par[x] = find(par[x]);
}
void unite(int x,int y)
{
    x = find(x);
    y = find(y);
    if (x == y) {
        return;
    }
    if (r[x]<r[y]) {
        par[x] = y;
        r[y]++;
    }
    else
    {
        par[y] = x;
        if (r[x] == r[y]) {
            r[x]++;
        }
    }
}
bool same(int x,int y)
{
    if (find(x) == find(y)) {
        return true;
    }
    else
        return false;
}
struct edge{
    int u,v,cost;
}es[22000];

void add_edge(int i,int a,int b,int c)
{
    es[i].u = a;
    es[i].v = b;
    es[i].cost = c;
}
bool comp(const edge& e1,const edge& e2)
{
    return e1.cost>e2.cost;
}
int kruskal()
{
    sort(es, es+m, comp);
    init(n);
    int res = 0;
    cnt = 0;
    for (int i = 0; i<m; i++) {
        if (!same(es[i].u, es[i].v)) {
        //如果没有在一个集合中就加进去。
            cnt++;
            unite(es[i].u, es[i].v);
            res += es[i].cost;
        }
    }
    return res;
}
int main()
{
    while (cin>>n>>m) {
        for (int i = 0; i<m; i++) {
            int a,b,c;
            cin>>a>>b>>c;
            add_edge(i, a, b,c);
        }
        int sum;
        sum = kruskal();
        if (cnt == n-1) {
            cout<<sum<<endl;
        }
        else
            cout<<-1<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值