HDU 4280 Island Transport (最大流)

15 篇文章 0 订阅

Island Transport

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 9242    Accepted Submission(s): 2986


Problem Description
  In the vast waters far far away, there are many islands. People are living on the islands, and all the transport among the islands relies on the ships.
  You have a transportation company there. Some routes are opened for passengers. Each route is a straight line connecting two different islands, and it is bidirectional. Within an hour, a route can transport a certain number of passengers in one direction. For safety, no two routes are cross or overlap and no routes will pass an island except the departing island and the arriving island. Each island can be treated as a point on the XY plane coordinate system. X coordinate increase from west to east, and Y coordinate increase from south to north.
  The transport capacity is important to you. Suppose many passengers depart from the westernmost island and would like to arrive at the easternmost island, the maximum number of passengers arrive at the latter within every hour is the transport capacity. Please calculate it.
 

Input
  The first line contains one integer T (1<=T<=20), the number of test cases.
  Then T test cases follow. The first line of each test case contains two integers N and M (2<=N,M<=100000), the number of islands and the number of routes. Islands are number from 1 to N.
  Then N lines follow. Each line contain two integers, the X and Y coordinate of an island. The K-th line in the N lines describes the island K. The absolute values of all the coordinates are no more than 100000.
  Then M lines follow. Each line contains three integers I1, I2 (1<=I1,I2<=N) and C (1<=C<=10000) . It means there is a route connecting island I1 and island I2, and it can transport C passengers in one direction within an hour.
  It is guaranteed that the routes obey the rules described above. There is only one island is westernmost and only one island is easternmost. No two islands would have the same coordinates. Each island can go to any other island by the routes.
 

Output
  For each test case, output an integer in one line, the transport capacity.
 

Sample Input
  
  
2 5 7 3 3 3 0 3 1 0 0 4 5 1 3 3 2 3 4 2 4 3 1 5 6 4 5 3 1 4 4 3 4 2 6 7 -1 -1 0 1 0 2 1 0 1 1 2 3 1 2 1 2 3 6 4 5 5 5 6 3 1 4 6 2 5 5 3 6 4
 

Sample Output
  
  
9 6
 

Source
 

Recommend
liuyiding   |   We have carefully selected several similar problems for you:   4277  4267  4268  4269  4270 
 

题意:
最大流裸题。
POINT:
虽然裸,但是我以前一直用vector和queue写,这题用了会超时。用数组邻接表和队列数组做,dinic 9500ms卡过。
很难受。

#pragma comment(linker,"/STACK:16777216")
#include <vector>
#include <stdio.h>
#include <iostream>
#include <stdio.h>
#include <queue>
#include <string.h>
using namespace std;
#define LL long long
typedef pair<int,int> pr;
const int maxn =200100;
const int inf = 0x3f3f3f3f;
int s,t;
int head[maxn];
int n,m;
int sz=0;
struct edge
{
    int from,to,flow,cap,nxt;
}len[maxn];
void add(int u,int v,int c)
{
    len[sz].from=u;
    len[sz].to=v;
    len[sz].flow=0;
    len[sz].cap=c;
    len[sz].nxt=head[u];
    head[u]=sz++;
}
void init()
{
    sz=0;
    memset(head,-1,sizeof head);
}
int d[maxn];
bool bfs()
{
    int q[maxn<<1];
    int vis[maxn];
    memset(vis,0,sizeof vis);
    memset(d,0,sizeof d);
    d[s]=1;
    int hd=1,wei=1;
    vis[s]=1;
    q[wei++]=s;
    while(hd!=wei)
    {
        int u=q[hd++];
        for(int i=head[u];i!=-1;i=len[i].nxt)
        {
            if(!vis[len[i].to]&&len[i].cap>len[i].flow)
            {
                vis[len[i].to]=1;
                d[len[i].to]=d[u]+1;
                q[wei++]=len[i].to;
            }
        }
    }
    return vis[t];
}
int cur[maxn];
int dfs(int u,int a)
{
    if(u==t||a==0) return a;
    int flw=0,f;
    for(int i=head[u];i!=-1;i=len[i].nxt)
    {
        if(d[len[i].to]-1==d[u]&&(f=dfs(len[i].to,min(a,len[i].cap-len[i].flow)))>0)
        {
            flw+=f;
            len[i].flow+=f;
            len[i^1].flow-=f;
            a-=f;
        }
        if(a==0) break;
    }
    if(flw==0) d[u]=-1;
    return flw;
}
int maxflow()
{
    int ans=0;
    while(bfs())
    {
        ans+=dfs(s,inf);
    }
    return ans;
    
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d %d",&n,&m);
        init();
        int ek=-110000,wk=110000,w,e;
        for(int i=1;i<=n;i++)
        {
            int x,y;scanf("%d %d",&x,&y);
            if(x<wk)
            {
                wk=x;
                w=i;
            }
            if(x>ek)
            {
                ek=x;
                e=i;
            }
        }
        s=e,t=w;
        for(int i=1;i<=m;i++)
        {
            int u,v,w;scanf("%d %d %d",&u,&v,&w);
            add(u,v,w);
            add(v,u,w);
        }
        printf("%d\n",maxflow());
    }
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值