POJ 1364 King 差分约束系统

Description

Once, in one kingdom, there was a queen and that queen was expecting a baby. The queen prayed: “If my child was a son and if only he was a sound king.” After nine months her child was born, and indeed, she gave birth to a nice son.
Unfortunately, as it used to happen in royal families, the son was a little retarded. After many years of study he was able just to add integer numbers and to compare whether the result is greater or less than a given integer number. In addition, the numbers had to be written in a sequence and he was able to sum just continuous subsequences of the sequence.

The old king was very unhappy of his son. But he was ready to make everything to enable his son to govern the kingdom after his death. With regards to his son’s skills he decided that every problem the king had to decide about had to be presented in a form of a finite sequence of integer numbers and the decision about it would be done by stating an integer constraint (i.e. an upper or lower limit) for the sum of that sequence. In this way there was at least some hope that his son would be able to make some decisions.

After the old king died, the young king began to reign. But very soon, a lot of people became very unsatisfied with his decisions and decided to dethrone him. They tried to do it by proving that his decisions were wrong.

Therefore some conspirators presented to the young king a set of problems that he had to decide about. The set of problems was in the form of subsequences Si = {aSi, aSi+1, …, aSi+ni} of a sequence S = {a1, a2, …, an}. The king thought a minute and then decided, i.e. he set for the sum aSi + aSi+1 + … + aSi+ni of each subsequence Si an integer constraint ki (i.e. aSi + aSi+1 + … + aSi+ni < ki or aSi + aSi+1 + … + aSi+ni > ki resp.) and declared these constraints as his decisions.

After a while he realized that some of his decisions were wrong. He could not revoke the declared constraints but trying to save himself he decided to fake the sequence that he was given. He ordered to his advisors to find such a sequence S that would satisfy the constraints he set. Help the advisors of the king and write a program that decides whether such a sequence exists or not.

Input

The input consists of blocks of lines. Each block except the last corresponds to one set of problems and king’s decisions about them. In the first line of the block there are integers n, and m where 0 < n <= 100 is length of the sequence S and 0 < m <= 100 is the number of subsequences Si. Next m lines contain particular decisions coded in the form of quadruples si, ni, oi, ki, where oi represents operator > (coded as gt) or operator < (coded as lt) respectively. The symbols si, ni and ki have the meaning described above. The last block consists of just one line containing 0.

Output

The output contains the lines corresponding to the blocks in the input. A line contains text successful conspiracy when such a sequence does not exist. Otherwise it contains text lamentable kingdom. There is no line in the output corresponding to the last “null” block of the input.

Sample Input

4 2
1 2 gt 0
2 2 lt 2
1 2
1 0 gt 0
1 0 lt 0
0

Sample Output

lamentable kingdom
successful conspiracy


题目大意:现在有个国王的儿子,他很笨,只会回答一些关于一个序列的问题,现在对于这个序列有m个约束条件,其中每个约束条件被表示为l,r,opt,k,如果opt为lt表示小于号,opt为gt表示大于号,表示a[l]到a[r]中所有数的和opt一个k值,然后问是否有这样的一个数列,其实就是SPFA判一下环就好了,如果有环,则说明约束条件有问题,矛盾,就好比说A比B大,B比C大,C比A大,这是矛盾的
这道题get到一个新细节,就是我们查分约束都是要大于等于或者小于等于,所以我们如果要求A>B则可以转化为A >= B + 1


#include <cstdio>
#include <cstring>
#include <queue>
#include <iostream>
using namespace std;

const int MAXN = 100;
int tail, head[MAXN], dis[MAXN], cnt[MAXN];
struct Line{ int to, nxt, flow; }line[ MAXN * MAXN ];
bool vis[MAXN];
void init() {
    tail = 0; 
    memset( head, 0, sizeof( head ) );
    memset( dis, 0, sizeof( dis ) );
}

void add_line( int from, int to, int flow ) {
    line[++tail].nxt = head[from];
    line[tail].to = to;
    line[tail].flow = flow;
    head[from] = tail;
}
bool SPFA( int S, int n ) {
    queue<int>q; while( !q.empty() ) q.pop();
    memset( dis, 0x3f, sizeof( dis ) );
    memset( cnt, 0, sizeof( cnt ) );
    memset( vis, false, sizeof( vis ) );
    dis[S] = 0; q.push( S ); cnt[S]++;
    vis[S] = true; 
    while( !q.empty() ) {
        int u = q.front(); q.pop(); vis[u] = false;
        for( register int i = head[u]; i; i = line[i].nxt ) {
            int v = line[i].to;
            if( dis[v] > dis[u] + line[i].flow ) {
                dis[v] = dis[u] + line[i].flow;
                if( vis[v] ) continue;
                vis[v] = true;
                q.push(v);
                cnt[v]++;
                if( cnt[v] > n ) {
                    return false;
                }
            }
        }
    }
    return true;
}
int main( ) { int n, m;
    while( scanf( "%d", &n ), n ) {
        scanf( "%d", &m ); int ff, tt, ww; char opt[10];
        init();
        for( register int i = 1; i <= m; i++ ) {
            scanf( "%d%d%s%d", &ff, &tt, opt, &ww );
            if( opt[0] == 'g' ) add_line( ff + tt + 1, ff,  - ww - 1 );
            else                add_line( ff, ff + tt + 1, ww - 1 );
        }
        for( register int i = 1; i <= n + 1; i++ ) add_line( 0, i, 0 );
        if( !SPFA( 0, n + 2 ) ) puts("successful conspiracy");
        else                    puts("lamentable kingdom");
    }
    return 0;
}

这里写图片描述

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值