PHP 5.4升级5.6后访问SQLServer失败

原创 2016年08月29日 17:30:17

首先是升级后根本忘记还有SQLServer连接这回事了。

结果客户端莫名其妙报错了。一直觉得是数据库自己的问题。连上去一看,原来报告sqlsvr_connect不能用了。恍然大悟。

1. 修改php.ini

extension=php_mssql.dll
extension=php_sqlsrv_54_ts.dll

2. 拷贝sqlsrv ext文件到php/ext目录。


结果还是不行。

后来一看版本不对,重新下过呗。

下载的SQLSRV32.exe。解压拷贝。

还是不行。尼玛还需要一个Microsoft ODBC Driver 11 for SQL Server 

继续安装。搞定。


所有的东西可以从这里下载

https://msdn.microsoft.com/en-us/library/cc296170.aspx

php5.2 、5.3、5.4、5.5、5.6 各个版本升级不兼容点

最近工作中将php5.2升级到php5.6,在升级的过程中,需要对php各个版本之间的不兼容的问题进行讨论和测试论证。依据php版本不兼容 分支说明 , 分别在多个版本之间进行了测试,分享如下: p...

通过yum把PHP5.4升级到PHP5.6

通过yum把PHP5.4升级到PHP5.5

PHP 5.3、5.4、5.5、5.6 中的新特性

PHP 5.6 1、可以使用表达式定义常量 https://php.net/manual/zh/migration56.new-features.php 在之前的 PHP 版本中,必...

PHP 5.2 5.3 5.5 5.4 5.6 对比以及功能详解

php5.2.x php5.3.x php5.4.x php5.5.x php5.6.x 对比详解 截至目前(2014.2), PHP 的最新稳定版本是 PHP5.5, 但有差不多一半的用户仍在...

PHP 5.2、5.3、5.4、5.5、5.6 对比以及功能详解

PHP 5.2、5.3、5.4、5.5、5.6 对比以及功能详解
  • nohaoye
  • nohaoye
  • 2016年04月02日 00:31
  • 7049

PHP 5.3、5.4、5.5、5.6 中的新特性(转、侵删)

PHP 5.6 1、可以使用表达式定义常量 https://php.net/manual/zh/migration56.new-features.php 在之前的 PHP 版本中,必须使用静态值...

PHP 5.2、5.3、5.4、5.5、5.6 对比以及功能详解

PHP 5.2、5.3、5.4、5.5、5.6 对比以及功能详解 截至目前(2014.2), PHP 的最新稳定版本是 PHP5.5, 但有差不多一半的用户仍在使用已经不在维护 [注] 的 PH...

PHP 5.3、5.4、5.5、5.6 中的新特性

PHP 5.61、可以使用表达式定义常量https://php.net/manual/zh/migration56.new-features.php在之前的 PHP 版本中,必须使用静态值来定义常量,...

Apache2.2+PHP5.4+MySql5.6服务器平台搭建

★理清逻辑:首先安装apache与php,再使apache与php连接,这样机器才具备解释php代码的功能。最后安装mysql,使php与mysql关联,这样才能够利用php中的函数进行数据库操作。这...

[安装教程]windows32+apache2.4+mysql5.6+php5.4安装图文啰嗦版

准备工具: Apache httpd-2.4.12-x86 ———–> http://httpd.apache.org/download.cgi Php php-5.4.38-Win32...
  • ophirl
  • ophirl
  • 2015年04月20日 17:19
  • 281
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:PHP 5.4升级5.6后访问SQLServer失败
举报原因:
原因补充:

(最多只允许输入30个字)