poj 1113 Wall 计算几何 凸包 Graham扫描

Wall
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 35684 Accepted: 12177

Description

Once upon a time there was a greedy King who ordered his chief Architect to build a wall around the King's castle. The King was so greedy, that he would not listen to his Architect's proposals to build a beautiful brick wall with a perfect shape and nice tall towers. Instead, he ordered to build the wall around the whole castle using the least amount of stone and labor, but demanded that the wall should not come closer to the castle than a certain distance. If the King finds that the Architect has used more resources to build the wall than it was absolutely necessary to satisfy those requirements, then the Architect will loose his head. Moreover, he demanded Architect to introduce at once a plan of the wall listing the exact amount of resources that are needed to build the wall. 

Your task is to help poor Architect to save his head, by writing a program that will find the minimum possible length of the wall that he could build around the castle to satisfy King's requirements. 

The task is somewhat simplified by the fact, that the King's castle has a polygonal shape and is situated on a flat ground. The Architect has already established a Cartesian coordinate system and has precisely measured the coordinates of all castle's vertices in feet.

Input

The first line of the input file contains two integer numbers N and L separated by a space. N (3 <= N <= 1000) is the number of vertices in the King's castle, and L (1 <= L <= 1000) is the minimal number of feet that King allows for the wall to come close to the castle. 

Next N lines describe coordinates of castle's vertices in a clockwise order. Each line contains two integer numbers Xi and Yi separated by a space (-10000 <= Xi, Yi <= 10000) that represent the coordinates of ith vertex. All vertices are different and the sides of the castle do not intersect anywhere except for vertices.

Output

Write to the output file the single number that represents the minimal possible length of the wall in feet that could be built around the castle to satisfy King's requirements. You must present the integer number of feet to the King, because the floating numbers are not invented yet. However, you must round the result in such a way, that it is accurate to 8 inches (1 foot is equal to 12 inches), since the King will not tolerate larger error in the estimates.

Sample Input

9 100
200 400
300 400
300 300
400 300
400 400
500 400
500 200
350 200
200 200

Sample Output

1628


题意:
给定多边形城堡的n个顶点,绕城堡外面建一个围墙,围住所有点,并且墙与所有点的距离至少为L,求这个墙最小的长度。
 
解题思路:
城堡围墙长度最小值 = 城堡顶点坐标构成的散点集的凸包总边长 + 半径为L的圆周长


#include <cstdio>  
#include <string> 
#include <iostream>
#include <cstring>
#include <cctype>
#include <algorithm>
#include <functional>
#include <cstdlib>
#include <list>
#include <utility>
#include <vector>
#include <bitset>
#include <cmath>
using namespace std;

typedef long long LL;
const int maxn = 1e3 + 5;
const double EPS = 1e-6;
const double PI = acos(-1.0);

//考虑误差的加法运算
double Add(double a, double b) {
    if (abs(a + b) < EPS * (abs(a) + abs(b))) return 0;
    return a + b;
}

//二维向量结构体
struct Point2 {
    double x, y;

    Point2() {}

    Point2(double x, double y) : x(x), y(y) {}

    Point2 operator+(const Point2& p) const {
        return Point2(Add(x, p.x), Add(y, p.y));
    }

    Point2 operator-(const Point2& p) const {
        return Point2(Add(x, -p.x), Add(y, -p.y));
    }

    Point2 operator*(double d) {
        return Point2(x*d, y*d);
    }

    //內积
    double Dot(const Point2& p) const {
        return Add(x*p.x, y*p.y);
    }

    //外积
    double Det(const Point2& p) const {
        return Add(x*p.y, -y*p.x);
    }
};

bool CmpXY(const Point2& p, const Point2& q) {
    if (p.x != q.x) return p.x < q.x;
    return p.y < q.y;
}

//求凸包
vector<Point2> GrahamScan(Point2* ps, int n) {
    sort(ps, ps + n, CmpXY);

    int k = 0; //凸包的顶点数
    vector<Point2> qs(n << 1);

    //构造凸包的下侧
    for (int i = 0; i < n; ++i) {
        while (k > 1 && (qs[k - 1] - qs[k - 2]).Det(ps[i] - qs[k - 1]) <= 0) --k;
        qs[k++] = ps[i];
    }

    //构造凸包上侧
    for (int i = n - 2, t = k; i >= 0; --i) {
        while (k > t && (qs[k - 1] - qs[k - 2]).Det(ps[i] - qs[k - 1]) <= 0) --k;
        qs[k++] = ps[i];
    }

    qs.resize(k - 1);
    return qs;
}

//两点间距离
double Dist(const Point2& p, const Point2& q) {
    return sqrt((p - q).Dot(p - q));
}

double Solve(Point2* p, int n, int r) {
    vector<Point2> convexHull = GrahamScan(p, n);
    double len = Dist(*convexHull.begin(), *(convexHull.end() - 1));
    for (int i = 1; i < convexHull.size(); ++i) {
        len += Dist(convexHull[i], convexHull[i - 1]);
    }
    len += PI * 2 * r;
    return len;
}

int main() {
#ifdef NIGHT_13
    freopen("in.txt", "r", stdin);
#endif
    std::ios::sync_with_stdio(false);

    int n, r;
    Point2 p[maxn];

    while (scanf("%d%d", &n, &r) == 2) {
        for (int i = 0; i < n; ++i) {
            scanf("%lf%lf", &p[i].x, &p[i].y);
        }
        printf("%.0f\n", Solve(p, n, r));
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值