HDU1010弱智搜索

其实这里边就一个奇偶剪枝值得看
再就是注意全局变量的多组数据的初始化
没啥好说的了…
不过需要注意的是这个题不能用bfs
bfs只能求出最短的来
求出最短的就停了,问题是这个东西最短的不一定就是答案
所以用dfs
bfs我跪了无数次
Problem Description

The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.

Input

The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

‘X’: a block of wall, which the doggie cannot enter;
‘S’: the start point of the doggie;
‘D’: the Door; or
‘.’: an empty block.

The input is terminated with three 0’s. This test case is not to be processed.

Output

For each test case, print in one line “YES” if the doggie can survive, or “NO” otherwise.

Sample Input

4 4 5
S.X.
..X.
..XD
….
3 4 5
S.X.
..X.
…D
0 0 0

Sample Output

NO
YES

上代码

#include<iostream>
#include<cstdlib>
using namespace std;
struct p
{
    int x, y, t;
};
p start;
p endd;
char map[9][9];
int jiyou[7][7] = 
{
{0,1,0,1,0,1,0},
{1,0,1,0,1,0,1},
{0,1,0,1,0,1,0},
{1,0,1,0,1,0,1},
{0,1,0,1,0,1,0},
{1,0,1,0,1,0,1},
{0,1,0,1,0,1,0}
};
int yuyu[4][2] = { {1,0},{-1,0},{0,1},{0,-1} };
int yy = 0;
int book[9][9] = { 0 };
int n, m, t;
void dfs(p u)
{
    if (yy == 1)return;
    if (u.x==endd.x&&u.y==endd.y&&u.t == 0)
    {
        cout<< "YES" << endl;
        yy = 1;
        return;
    }
    else if (u.t <= 0 && map[u.x][u.y] != 'D')return;
    int qq, ww;
    for (int a = 0;a < 4;a++)
    {
        qq = u.x + yuyu[a][0];
        ww = u.y + yuyu[a][1];
        if (qq >= 0 && qq < n&&ww >= 0 && ww < m)
        {
            if (map[qq][ww] != 'X'&&book[qq][ww]==0)
            {
                book[qq][ww] = 1;
                dfs({ qq,ww,u.t - 1 });
                book[qq][ww] = 0;
            }
        }
    }
}
int main()
{
    while (cin>>n>>m>>t)
    {
        if (n == 0 && m == 0 && t == 0)break;
        yy = 0;
        for (int a = 0;a < 7;a++)
        {
            for (int b = 0;b < 7;b++)
            {
                book[a][b] = 0;
            }
        }
        for (int a = 0;a < n;a++)
        {
            for (int b = 0;b < m;b++)
            {
                cin>>map[a][b];
                if (map[a][b] == 'S')
                {
                    start = { a,b,t };
                    book[a][b] = 1;
                }
                if (map[a][b] == 'D')
                {
                    endd.x = a;
                    endd.y = b;
                }
            }
        }
        if (t % 2 == 0)
        {
            if (jiyou[start.x][start.y] != jiyou[endd.x][endd.y])
            {
                cout << "NO" << endl;
                yy = 2;
            }
            else dfs(start);
        }
        else
        {
            if (jiyou[start.x][start.y] == jiyou[endd.x][endd.y])
            {
                cout << "NO" << endl;
                yy = 2;
            }
            else dfs(start);
        }
        if (yy == 0)cout << "NO" << endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值