A. (网预)Saber's Conjecture 第十一届北京邮电大学程序设计竞赛 - 热身赛 (1)

时间限制 1000 ms 内存限制 65536 KB

题目描述

In a parallel universe, young Saber-chan does not have a humongous appetite, instead, she likes studying math in her spare time. This afternoon when Saber-chan is plunged in her study, she came across an interesting conjecture: for any even number n greater than or equal to 4, there exists at least one pair of prime numbers p1 and p2 such that n=p1+p2.

This conjecture is actually known as the Goldbach’s conjecture. It is has not been proved nor refused yet. However in this universe, there are more programmers than mathematicians, people tend to prove math findings by programs. As the King of Knights and King of Britain, Saber-chan orders you to write a program that reports the number of all the pairs of prime numbers satisfying the condition in the conjecture for a given even number.

A sequence of even numbers is given as input. Corresponding to each number, the program should output the number of pairs mentioned above. Notice that Saber-chan is interested in the number of essentially different pairs and therefore you should not count (p1,p2) and (p2,p1) separately as two different pairs.

输入格式

An integer is given in each input line. You may assume that each integer is even, and is greater than or equal to 4 and less than 215. The end of the input is indicated by a number 0.

输出格式

Each output line should contain an integer number. No other characters should appear in the output.

输入样例

6
10
12
0

输出样例

1
2
1
#include <stdio.h>
#include<string.h>
#include<stdlib.h>


int isprime(int a){//判断给定的a是否是素数
    int i=2;
    int sign=0;
    while(i<a){
        if(a%i==0){
            sign=1;
            break;
        }
        i++;
    }
    if(sign==0&&a!=1) return 1;//是素数
    if(sign==1||a==1) return 0;
};


int main(){
    int num;//需要判断的数字
    int i=2,j;
    int result=0;
    scanf("%d",&num);
    while(num!=0){
        for(i=2;i<=num/2;i++){
            j=num-i;
            if(isprime(i)==1&&isprime(j)==1)
               result++;
        }
        printf("%d\n",result);
        result=0;
        scanf("%d",&num);
    }
    return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值