BZOJ1647: [Usaco2007 Open]Fliptile 翻格子游戏 Dfs

1647: [Usaco2007 Open]Fliptile 翻格子游戏

Time Limit: 5 Sec   Memory Limit: 64 MB
Submit: 566   Solved: 228

Description

Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M x N grid (1 <= M <= 15; 1 <= N <= 15) of square tiles, each of which is colored black on one side and white on the other side. As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make. Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the output when considered as a string. If the task is impossible, print one line with the word "IMPOSSIBLE".

 约翰知道,那些高智力又快乐的奶牛产奶量特别高.所以他做了一个翻瓦片的益智游戏来娱乐奶牛.在一个M×N(1≤M,N≤15)的骨架上,每一个格子里都有一个可以翻转的瓦片.瓦片的一面是黑色的,而另一面是白色的.对一个瓦片进行翻转,可以使黑变白,也可以使白变黑.然而,奶牛们的蹄子是如此的巨大而且笨拙,所以她们翻转一个瓦片的时候,与之有公共边的相邻瓦片也都被翻转了.那么,这些奶牛们最少需要多少次翻转,使所有的瓦片都变成白面向上呢?如杲可以做到,输出字典序最小的结果(将结果当成字符串处理).如果不能做到,输出“IMPOSSIBLE”.

Input

* Line 1: Two space-separated integers: M and N

* Lines 2..M+1: Line i+1 describes the colors (left to right) of row i of the grid with N space-separated integers which are 1 for black and 0 for white

    第1行输入M和N,之后M行N列,输入游戏开始时的瓦片状态.0表示白面向上,1表示黑面向上.

Output

* Lines 1..M: Each line contains N space-separated integers, each specifying how many times to flip that particular location.

    输出M行,每行N个用空格隔开的整数,表示对应的格子进行了多少次翻转.

Sample Input

4 4
1 0 0 1
0 1 1 0
0 1 1 0
1 0 0 1


Sample Output

0 0 0 0
1 0 0 1
1 0 0 1
0 0 0 0

OUTPUT DETAILS:

After flipping at row 2 column 1, the board will look like:
0 0 0 1
1 0 1 0
1 1 1 0
1 0 0 1

After flipping at row 2 column 4, the board will look like:
0 0 0 0
1 0 0 1
1 1 1 1
1 0 0 1

After flipping at row 3 column 1, the board will look like:
0 0 0 0
0 0 0 1
0 0 1 1
0 0 0 1

After flipping at row 3 column 4, the board will look like:
0 0 0 0
0 0 0 0
0 0 0 0
0 0 0 0

Another solution might be:
0 1 1 0
0 0 0 0
0 0 0 0
0 1 1 0
but this solution is lexicographically higher than the solution above.

题解:

我们可以只对第一行进行暴搜,因为对于第i行(i>=2)的数字只取决于它正上方的数字(mp[i-1][j])是1还是0,因为这是mp[i-1][j]最后的一次修改机会,我们必须把它更改成0.
如果mp[i-1][j]=1,这个格子就必须要翻,如果mp[i-1][j]=0,这个格子就一定不能翻。当所有的数都按照规则翻完后,如果图内没有1存在则合法,否则return。题目要求首先满足翻的次数最少,其次是按照字典序的大小排序。时间复杂度O(n^2*2^n).
#include<cmath>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
const int N=20;
const int inf=1707185547;
int n,m,f[N][N],ans[N][N],p[N][N],mp[N][N],mn=inf;
void dfs(int x)
{
	if(x>m)
	{
		for(int i=1;i<=n;i++)
		for(int j=1;j<=m;j++)
		p[i][j]=mp[i][j];
		for(int i=1;i<=m;i++)
		if(f[1][i])
		{
		    p[1][i]^=1,p[2][i]^=1;
		    p[1][i+1]^=1,p[1][i-1]^=1;
		}
		for(int i=2;i<=n;i++)
		for(int j=1;j<=m;j++)
		{
			if(p[i-1][j]==1)
			{
			    f[i][j]=1;
				p[i][j]^=1;
				p[i][j+1]^=1,p[i][j-1]^=1;
				p[i+1][j]^=1,p[i-1][j]^=1;
			}
			else f[i][j]=0;
			if(p[i-1][j]) return;
		}
		bool flag=false;
		for(int i=1;i<=n;i++)
		for(int j=1;j<=m;j++)
		if(p[i][j])
		{
			flag=true;
			break;
		}
		if(!flag)
		{
			int tot=0;
			for(int i=1;i<=n;i++)
			for(int j=1;j<=m;j++)
			if(f[i][j]) tot++;
			if(tot>=mn) return;
			mn=tot;
			for(int i=1;i<=n;i++)
			for(int j=1;j<=m;j++)
			ans[i][j]=f[i][j];
		}
		return;
	}
	for(int i=0;i<=1;i++)
	{
		f[1][x]=i;
		dfs(x+1);
	}
}
int main()
{
	scanf("%d%d",&n,&m);
	for(int i=1;i<=n;i++)
	for(int j=1;j<=m;j++)
	scanf("%d",&mp[i][j]);
	dfs(1);
	if(mn==inf) printf("IMPOSSIBLE");
	else
	{
		for(int i=1;i<=n;i++)
		{
			for(int j=1;j<m;j++)
			printf("%d ",ans[i][j]);
			printf("%d\n",ans[i][m]);
		}
	}
}


  • 3
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值