关闭

Android 6.0 之后无法找到 org.apache.http 包的问题

标签: androidorg-apache
876人阅读 评论(0) 收藏 举报
分类:

随着Android 6.0的sdk包的更新,发现找不到org.apache.http的包了,

这里写图片描述
大概意思就是,Android 6.0不再支持 Apache HTTP client。 请使用 HttpURLConnection 代替。想要继续使用 Apache HTTP client 的,请添加如上代码。

解决方法一
如上所述,

android {
    useLibrary 'org.apache.http.legacy'
    }

解决方法二
直接下载org.apache.http.legacy.jar这个jar包,加入libs文件夹就行了。

经过个人验证,还是用方法二比较简单,因为我在使用方法一的时候,因为项目之前是5.0的时候创建的,现在把sdk升级到23,结果加入这句话后,要修改很多地方,如果直接创建的时候就是23就没有问题了。

0
0

查看评论
* 以上用户言论只代表其个人观点,不代表CSDN网站的观点或立场
    个人资料
    • 访问:263819次
    • 积分:3099
    • 等级:
    • 排名:第12363名
    • 原创:81篇
    • 转载:16篇
    • 译文:0篇
    • 评论:114条
    最新评论