HDU 1698 Just a Hook(线段树-区间更新)

Just a Hook

 

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 30792    Accepted Submission(s): 15169

 

 

Problem Description

In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.



Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.

 

 

Input

The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.

 

 

Output

For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.

 

 

Sample Input

 

1 10 2 1 5 2 5 9 3

 

 

Sample Output

 

Case 1: The total value of the hook is 24.

 

NOTE:1、加延迟标记

2、输入输出用scanf和printf

3、注意线段树的size

#include <iostream>
#include <string>
#include <cstring>
#include <algorithm>
#include <cstdio>
#include <cstdlib>
#include <vector>
#include <map>
#include <cmath>

using namespace std;
struct SegTreeNode
{
	int value;
	int flag;
}SegTree[300010];
void Build(int root, int Begin, int End)
{
	SegTree[root].flag=0;
	if(Begin == End)
	{
		SegTree[root].value = 1;
		return;
	}
	int mid = (Begin+End)>>1;
	Build(root<<1, Begin, mid);
	Build(root<<1|1, mid+1, End);

	SegTree[root].value = SegTree[root<<1].value+SegTree[root<<1|1].value;
}

void pushdown(int root, int Begin, int End)
{
	if(SegTree[root].flag!=0)
	{
		SegTree[root<<1].flag = SegTree[root].flag;
		SegTree[root<<1|1].flag = SegTree[root].flag;

		int mid = (Begin+End)>>1;
		SegTree[root<<1].value = SegTree[root].flag*(mid-Begin+1);
		SegTree[root<<1|1].value = SegTree[root].flag*(End-mid);

		SegTree[root].flag=0;
	}
}
void Update(int root, int rBegin, int rEnd, int aBegin, int aEnd, int add)
{
	 if(aBegin>rEnd||aEnd<rBegin)
        return ;
	if(aBegin<=rBegin&&aEnd>=rEnd)
	{
		SegTree[root].value=add*(rEnd-rBegin+1);
		SegTree[root].flag=add;
		return;
	}

	pushdown(root, rBegin, rEnd);
	int mid = (rBegin+rEnd)>>1;
	Update(root<<1,rBegin, mid, aBegin, aEnd,add);
	Update(root<<1|1, mid+1, rEnd, aBegin, aEnd, add);

	SegTree[root].value=SegTree[root<<1].value+SegTree[root<<1|1].value;
}
int main()
{
	int T,n,q,c=0;
	int l,r,add;
	scanf("%d",&T);

	while(T--)
	{
		scanf("%d",&n);
		scanf("%d",&q);
		Build(1,1,n);
		for(int i=0;i<q;i++)
		{
			scanf("%d%d%d",&l,&r,&add);
			Update(1,1,n,l,r,add);
		}
		printf("Case %d: The total value of the hook is %d.\n",(++c),SegTree[1].value);
	}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值