POJ Find them, Catch them

Language:
Find them, Catch them
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 33726 Accepted: 10411

Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.) 

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds: 

1. D [a] [b] 
where [a] and [b] are the numbers of two criminals, and they belong to different gangs. 

2. A [a] [b] 
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang. 

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."

Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output

Not sure yet.
In different gangs.
In the same gang.
题意:有一群人属于两个队伍每行给出两个人说明他们不属于同一个队问给出两个人他们属于一个队还是不同的队或是不确定
思路:并查集把给出的人分成几个集合每个集合之间的人的关系不确定,对同一个集合保存和本人不为同一队的人本着敌人的敌人便是朋友的原则用并查集同一集合为同一队不同集合为不同队
附AC代码 菜鸟就是菜鸟代码写的很乱
#include<cstdio>
#include<cstdlib>
#include<cstring>
using namespace std;
const int MAX=100010;
int father[MAX],pre[MAX],u[MAX];
int find(int x){
	return x==father[x]?x:father[x]=find(father[x]);
}
int Merge(int x){
	return x==u[x]?x:u[x]=Merge(u[x]);
}
int main()
{
	int t,m,n,i,j,a,b,c,d,e,f;
	char str[5];
	scanf("%d",&t);
	while(t--){
		scanf("%d%d",&n,&m);
		for(i=1;i<=n;++i){
			father[i]=u[i]=i;
			pre[i]=0;
		}
		for(i=0;i<m;++i){
			scanf("%s %d %d",str,&a,&b);
			e=a;f=b;
			if(str[0]=='D'){
				c=pre[a];d=pre[b];
				if(c){
					c=Merge(c);b=Merge(b);
					if(c!=b)u[c]=b;
				}
				if(d){
					a=Merge(a);d=Merge(d);
					if(a!=d)u[d]=a;
				}
				pre[e]=f;pre[f]=e;
				e=find(e);
				f=find(f);
				if(e!=f)father[e]=f;
			}
			else {
				if(find(a)!=find(b))printf("Not sure yet.\n");
				else {
					if(Merge(a)==Merge(b))printf("In the same gang.\n");
					else printf("In different gangs.\n");
				}
			}
		}
	}
	return 0;
} 
  • 0
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值