POJ2385Apple Catching【dp】

Apple Catching
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9265 Accepted: 4507

Description

It is a little known fact that cows love apples. Farmer John has two apple trees (which are conveniently numbered 1 and 2) in his field, each full of apples. Bessie cannot reach the apples when they are on the tree, so she must wait for them to fall. However, she must catch them in the air since the apples bruise when they hit the ground (and no one wants to eat bruised apples). Bessie is a quick eater, so an apple she does catch is eaten in just a few seconds.

Each minute, one of the two apple trees drops an apple. Bessie, having much practice, can catch an apple if she is standing under a tree from which one falls. While Bessie can walk between the two trees quickly (in much less than a minute), she can stand under only one tree at any time. Moreover, cows do not get a lot of exercise, so she is not willing to walk back and forth between the trees endlessly (and thus misses some apples).

Apples fall (one each minute) for T (1 <= T <= 1,000) minutes. Bessie is willing to walk back and forth at most W (1 <= W <= 30) times. Given which tree will drop an apple each minute, determine the maximum number of apples which Bessie can catch. Bessie starts at tree 1.

Input

* Line 1: Two space separated integers: T and W

* Lines 2..T+1: 1 or 2: the tree that will drop an apple each minute.

Output

* Line 1: The maximum number of apples Bessie can catch without walking more than W times.

Sample Input

7 2
2
1
1
2
2
1
1

Sample Output

6

Hint

INPUT DETAILS:

Seven apples fall - one from tree 2, then two in a row from tree 1, then two in a row from tree 2, then two in a row from tree 1. Bessie is willing to walk from one tree to the other twice.

OUTPUT DETAILS:

Bessie can catch six apples by staying under tree 1 until the first two have dropped, then moving to tree 2 for the next two, then returning back to tree 1 for the final two.
题意:一头牛在两颗树下捡苹果每分钟都有苹果随机从两颗树掉下给出掉苹果的树的编号牛起初在1树下最多在两颗树间移动w次求牛获得的最大苹果数
#include<stdio.h>
int dp[1010][35];
int apple[1010];
int Max(int a,int b)
{
	return a>b?a:b;
}
int main()
{
	int t,step,i,j;
	while(scanf("%d%d",&t,&step)!=EOF)
	{
		for(i=1;i<=t;++i)
		{
			scanf("%d",&apple[i]);
		}
		for(i=1;i<=t;++i)
		{
			dp[i][0]=dp[i-1][0]+(apple[i]&1);//没有走一步都为第一颗树上的苹果 
			for(j=1;j<=step;++j)
			{
				dp[i][j]=Max(dp[i-1][j-1]+((j+apple[i])&1),dp[i-1][j]+((j+apple[i])&1));//想要知道当前最大值只需知道前面的最大值即可由此的状态转移方程 
			}
		}
		printf("%d\n",dp[t][step]);
	}
	return 0;
}

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值