POJ3279Fliptile【经典搜索】

 

Language:
Fliptile
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 5095 Accepted: 1938

Description

Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M × N grid (1 ≤ M ≤ 15; 1 ≤ N ≤ 15) of square tiles, each of which is colored black on one side and white on the other side.

As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make.

Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the output when considered as a string. If the task is impossible, print one line with the word "IMPOSSIBLE".

Input

Line 1: Two space-separated integers:   M  and   N  
Lines 2.. M+1: Line   i+1 describes the colors (left to right) of row i of the grid with   N  space-separated integers which are 1 for black and 0 for white

Output

Lines 1.. M: Each line contains   N  space-separated integers, each specifying how many times to flip that particular location.

Sample Input

4 4
1 0 0 1
0 1 1 0
0 1 1 0
1 0 0 1

Sample Output

0 0 0 0
1 0 0 1
1 0 0 1
0 0 0 0

Source


 

题意:将1翻转为0翻转一个与其相邻的4个都翻转求最小翻转次数并输出那些翻转

#include<cstdio>
#include<cstdlib>
#include<cstring>
#define inf 0x3f3f3f3f
using namespace std;
int answer[20][20];
int flip[20][20];
int map[20][20];
int N,M;
int mov[][2]={0,1,0,-1,1,0,-1,0,0,0};
void input(){
	for(int i=0;i<N;++i){
		for(int j=0;j<M;++j){
			scanf("%d",&map[i][j]);
		}
	}
}
bool judge(int x,int y){
	int i,num=map[x][y];//num-map[x][y]表示周围和本身翻转次数如果通过周围的这几次翻转能使map[x][y]==0;则返回真 
	for(i=0;i<5;++i){
		int xx=x+mov[i][0];
		int yy=y+mov[i][1];
		if(xx>=0&&xx<N&&yy>=0&&yy<M){
			num=num+flip[xx][yy];
		}
	}
	return num&1;
}
int del(){
	for(int i=1;i<N;++i){//从第二行开始确定每行每个地板是否翻转 
		for(int j=0;j<M;++j){
			if(judge(i-1,j)){
				flip[i][j]=1;
			}
		}
	}
	for(int i=0;i<M;++i){
		if(judge(N-1,i))return -1;//判断上述翻转状态是否成立即判断最后一行是否有不成立 
	}
	int ans=0;//记录翻转次数;
	for(int i=0;i<N;++i){
		for(int j=0;j<M;++j){
			ans+=flip[i][j];//遍历翻转记录次数 
		}
	}
	return ans;
} 
bool solve(){
	int min=inf,ans=-1;
	for(int i=0;i<1<<M;++i){
		memset(flip,0,sizeof(flip));//初始化所有的地板都没有翻转过
		for(int j=0;j<M;++j){
			flip[0][j]=i>>j&1;//枚举第一行每个地板是否翻转1翻转0不翻转 
		}
		ans=del();
		if(ans!=-1&&ans<min){//如果此状态下需要翻转的次数小于当前最小翻转次数则更新结果按照题意不能等于 
			for(int i=0;i<N;++i){
				for(int j=0;j<M;++j){
					answer[i][j]=flip[i][j];
				}
			}
			min=ans; 
		}
	}
	if(min==inf)return false;
	return true;
}
void output(){
	if(solve()){
		for(int i=0;i<N;++i){
			for(int j=0;j<M;++j){
				printf(j?" %d":"%d",answer[i][j]);
			}
			printf("\n");
		}
	}
	else
		printf("IMPOSSIBLE\n");
}
int main()
{
	int i,j;
	while(scanf("%d%d",&N,&M)!=EOF){
		input();
		output();
	}
	return 0;
}


 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值