poj1474Video Surveillance【半平面交判断内核是否存在】

Language:
Video Surveillance
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 3555 Accepted: 1587

Description

A friend of yours has taken the job of security officer at the Star-Buy Company, a famous depart- ment store. One of his tasks is to install a video surveillance system to guarantee the security of the customers (and the security of the merchandise of course) on all of the store's countless floors. As the company has only a limited budget, there will be only one camera on every floor. But these cameras may turn around to look in every direction. 

The first problem is to choose where to install the camera for every floor. The only requirement is that every part of the room must be visible from there. In the following figure the left floor can be completely surveyed from the position indicated by a dot, while for the right floor, there is no such position, the given position failing to see the lower left part of the floor. 

Before trying to install the cameras, your friend first wants to know whether there is indeed a suitable position for them. He therefore asks you to write a program that, given a ground plan, de- termines whether there is a position from which the whole floor is visible. All floor ground plans form rectangular polygons, whose edges do not intersect each other and touch each other only at the corners. 

Input

The input contains several floor descriptions. Every description starts with the number n of vertices that bound the floor (4 <= n <= 100). The next n lines contain two integers each, the x and y coordinates for the n vertices, given in clockwise order. All vertices will be distinct and at corners of the polygon. Thus the edges alternate between horizontal and vertical. 

A zero value for n indicates the end of the input.

Output

For every test case first output a line with the number of the floor, as shown in the sample output. Then print a line stating "Surveillance is possible." if there exists a position from which the entire floor can be observed, or print "Surveillance is impossible." if there is no such position. 

Print a blank line after each test case.

Sample Input

4
0 0
0 1
1 1
1 0
8
0 0
0 2
1 2
1 1
2 1
2 2
3 2
3 0
0

Sample Output

Floor #1
Surveillance is possible.

Floor #2
Surveillance is impossible.

题意:求多边形内核是否存在

#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<cmath>
#include<algorithm>
#define eps 1e-10
using namespace std;
struct point{
	double x,y;
}A[110],p[110],q[110];
int N,endcnt,tempcnt;
void init(){
	for(int i=1;i<=N;++i){
		p[i]=A[i];
	}
	p[N+1]=p[1];p[0]=p[N];
	endcnt=N;
}
void getline(point p1,point p2,double &a,double &b,double &c){
	a=p2.y-p1.y;
	b=p1.x-p2.x;
	c=p2.x*p1.y-p2.y*p1.x;
}
point getinter(point p1,point p2,double a,double b,double c){
	double u=fabs(a*p1.x+b*p1.y+c);
	double v=fabs(a*p2.x+b*p2.y+c);
	point temp;
	temp.x=(p1.x*v+p2.x*u)/(u+v);
	temp.y=(p1.y*v+p2.y*u)/(u+v);
	return temp;
}
void cut(double a,double b,double c){
	tempcnt=0;
	for(int i=1;i<=endcnt;++i){
		if(a*p[i].x+b*p[i].y+c>=0)q[++tempcnt]=p[i];
		else {
			if(a*p[i-1].x+b*p[i-1].y+c>0){
				q[++tempcnt]=getinter(p[i],p[i-1],a,b,c);
			}
			if(a*p[i+1].x+b*p[i+1].y+c>0){
				q[++tempcnt]=getinter(p[i],p[i+1],a,b,c);
			}
		}
	}
	for(int i=1;i<=tempcnt;++i){
		p[i]=q[i];
	}
	p[tempcnt+1]=p[1];p[0]=p[tempcnt];
	endcnt=tempcnt;
}
void guizheng(){
	for(int i=1;i<=N;++i){
		q[i]=A[N-i+1];
	}
	for(int i=1;i<=N;++i){
		A[i]=q[i];
	}
}
void slove(){
//	guizheng();
	A[N+1]=A[1];
	init();
	for(int i=1;i<=N;++i){
		double a,b,c;
		getline(A[i],A[i+1],a,b,c);
		cut(a,b,c);
	}
	if(endcnt<=0)
		printf("Surveillance is impossible.\n");
	else 
		printf("Surveillance is possible.\n");
}
int main()
{
	int t=1,i;
	while(scanf("%d",&N),N){
		for(i=1;i<=N;++i){
			scanf("%lf%lf",&A[i].x,&A[i].y);
		}
		printf("Floor #%d\n",t++);
		slove();
		printf("\n");
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值