hdoj2412Party at Hali-Bula【树形dp】

Party at Hali-Bula

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2192    Accepted Submission(s): 773


Problem Description
Dear Contestant,

I'm going to have a party at my villa at Hali-Bula to celebrate my retirement from BCM. I wish I could invite all my co-workers, but imagine how an employee can enjoy a party when he finds his boss among the guests! So, I decide not to invite both an employee and his/her boss. The organizational hierarchy at BCM is such that nobody has more than one boss, and there is one and only one employee with no boss at all (the Big Boss)! Can I ask you to please write a program to determine the maximum number of guests so that no employee is invited when his/her boss is invited too? I've attached the list of employees and the organizational hierarchy of BCM.

Best,
--Brian Bennett

P.S. I would be very grateful if your program can indicate whether the list of people is uniquely determined if I choose to invite the maximum number of guests with that condition.
 

Input
The input consists of multiple test cases. Each test case is started with a line containing an integer n (1 ≤ n ≤ 200), the number of BCM employees. The next line contains the name of the Big Boss only. Each of the following n-1 lines contains the name of an employee together with the name of his/her boss. All names are strings of at least one and at most 100 letters and are separated by blanks. The last line of each test case contains a single 0.
 

Output
For each test case, write a single line containing a number indicating the maximum number of guests that can be invited according to the required condition, and a word Yes or No, depending on whether the list of guests is unique in that case.
 

Sample Input
  
  
6 Jason Jack Jason Joe Jack Jill Jason John Jack Jim Jill 2 Ming Cho Ming 0
 

Sample Output
  
  
4 Yes 1 No
 

基础树形dp;判断最优解得时候只需将当前解中的人dp[i][0]==dp[i][1]即可

#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
using namespace std;
const int maxn=410;
int boss[maxn];
bool vis[maxn];
int dp[maxn][2],n;
char str[maxn][maxn];
char namea[maxn],nameb[maxn];
void dfs(int k){
	vis[k]=true;
	for(int i=1;i<=n;++i){
		if(boss[i]==k){
			if(vis[i])continue;
			dfs(i);
			dp[k][1]+=dp[i][0];
			dp[k][0]+=max(dp[i][0],dp[i][1]);
		}
	}
}
bool find(int k){
	if(dp[k][0]==dp[k][1])return false;
	if(dp[k][1]>dp[k][0]){
		for(int i=1;i<=n;++i){
			if(boss[i]==k){
				for(int j=1;j<=n;++j){
					if(boss[j]==i){
						if(!find(j))return false; 
					}
				}
			}
		}
	}
	else {
		for(int i=1;i<=n;++i){
			if(boss[i]==k){
				if(!find(i))return false; 
			}
		}
	}
	return true;
}
int main()
{
	int i,j,k;
	while(scanf("%d",&n),n){
		int root=1,a,b,ans=2;
		memset(dp,0,sizeof(dp));
		memset(vis,false,sizeof(vis));
		scanf("%s",str[1]);
		for(i=1;i<n;++i){
			scanf("%s %s",namea,nameb);
			bool as=false,bs=false;
			for(j=1;j<ans;++j){
				if(strcmp(namea,str[j])==0){
					as=true;a=j;
				}
				if(strcmp(nameb,str[j])==0){
					bs=true;b=j;
				}
			}
			if(!as){
				strcpy(str[ans],namea);a=ans++;
			}
			if(!bs){
				strcpy(str[ans],nameb);b=ans++;
			}
			boss[a]=b;
		}
		for(i=1;i<=n;++i){
			dp[i][1]=1;
		}
		dfs(root);
		printf("%d",max(dp[root][0],dp[root][1]));
		if(find(root)){
			printf(" Yes\n");
		}
		else {
			printf(" No\n");
		}
	}
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值