hdoj5883The Best Path【欧拉回路】

The Best Path

Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 233    Accepted Submission(s): 102


Problem Description
Alice is planning her travel route in a beautiful valley. In this valley, there are  N  lakes, and  M  rivers linking these lakes. Alice wants to start her trip from one lake, and enjoys the landscape by boat. That means she need to set up a path which go through every river exactly once. In addition, Alice has a specific number ( a1,a2,...,an ) for each lake. If the path she finds is  P0P1...Pt , the lucky number of this trip would be  aP0XORaP1XOR...XORaPt . She want to make this number as large as possible. Can you help her?
 

Input
The first line of input contains an integer  t , the number of test cases.  t  test cases follow.

For each test case, in the first line there are two positive integers  N (N100000)  and  M (M500000) , as described above. The  i -th line of the next  N lines contains an integer  ai(i,0ai10000)  representing the number of the  i -th lake.

The  i -th line of the next  M  lines contains two integers  ui  and  vi  representing the  i -th river between the  ui -th lake and  vi -th lake. It is possible that  ui=vi .
 

Output
For each test cases, output the largest lucky number. If it dose not have any path, output "Impossible".
 

Sample Input
  
  
2 3 2 3 4 5 1 2 2 3 4 3 1 2 3 4 1 2 2 3 2 4
 

Sample Output
  
  
2 Impossible
 

Source
 

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#include<list>
#include<vector>
#include<map>
#include<set>
using namespace std;
typedef long long LL;
typedef pair<int,int>pii;
const int maxn=1000010;
int num[maxn];
int degree[maxn];
int father[maxn];
int Find(int x){
    return x==father[x]?x:father[x]=Find(father[x]);
}
int main()
{
    int t,n,m;cin>>t;
    while(t--){
        scanf("%d%d",&n,&m);
        for(int i=1;i<=n;++i){
            scanf("%d",&num[i]);
            father[i]=i;degree[i]=0;
        }int ans=0;
        for(int i=1;i<=m;++i){
            int a,b;
            scanf("%d%d",&a,&b);
            degree[a]++;degree[b]++;
            a=Find(a);b=Find(b);
            if(a!=b)father[a]=b;
        }
        bool sign=true;
        int root=Find(1);
        for(int i=1;i<=n;++i){
            if(Find(i)!=root){
                sign=false;break;
            }
        }
        int cnt=0;
        for(int i=1;i<=n;++i){
            if(degree[i]&1)cnt++;
        }
        if(sign&&(cnt==0||cnt==2)){
            ans=0;
            if(cnt==2){
                for(int i=1;i<=n;++i){
                    if(degree[i]&1){
                        ans^=num[i];
                        if(((degree[i]-1)/2)&1){
                            ans^=num[i];
                        }
                    }
                    else {
                        if(((degree[i])/2)&1){
                            ans^=num[i];
                        }
                    }
                }
                printf("%d\n",ans);
            }
            else {
                int cntx=0;
                for(int i=1;i<=n;++i){
                    if((degree[i]/2)&1){
                        cntx^=num[i];
                    }
                }
                for(int i=1;i<=n;++i){
                    ans=max(ans,cntx^num[i]);
                }
                printf("%d\n",ans);
            }
        }
        else {
            printf("Impossible\n");
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值