POJ 2182 Lost Cows

Description

N (2 <= N <= 8,000) cows have unique brands in the range 1..N. In a spectacular display of poor judgment, they visited the neighborhood ‘watering hole’ and drank a few too many beers before dinner. When it was time to line up for their evening meal, they did not line up in the required ascending numerical order of their brands.

Regrettably, FJ does not have a way to sort them. Furthermore, he’s not very good at observing problems. Instead of writing down each cow’s brand, he determined a rather silly statistic: For each cow in line, he knows the number of cows that precede that cow in line that do, in fact, have smaller brands than that cow.

Given this data, tell FJ the exact ordering of the cows.

Input

  • Line 1: A single integer, N

  • Lines 2..N: These N-1 lines describe the number of cows that precede a given cow in line and have brands smaller than that cow. Of course, no cows precede the first cow in line, so she is not listed. Line 2 of the input describes the number of preceding cows whose brands are smaller than the cow in slot #2; line 3 describes the number of preceding cows whose brands are smaller than the cow in slot #3; and so on.

Output

  • Lines 1..N: Each of the N lines of output tells the brand of a cow in line. Line #1 of the output tells the brand of the first cow in line; line 2 tells the brand of the second cow; and so on.

Sample Input
5
1
2
1
0

Sample Output
2
4
5
3
1

1 二分答案 + 树状数组
2 位置从后到前逆序考虑 树状数组的下标代表奶牛遍号,值为 0 或 1,初始时所有编号的奶 牛在树状数组中都是 1
3 二分当前位置的奶牛应该是哪一号,并且用树状数组统计编号 x 的 数之前还有多少头奶牛
4 找到这个位置上的编号后,将树状数组中对应编号的奶牛删除(改 成 0)

#include<iostream>
#include<cstdio>
int n,a[8005],b[8005],c[8005];
using namespace std;
int lowbit(int x)
{
    return x&-x;
}
inline void chg(int x,int v)//在x位置增加1 
{
    while(x<=n)
    {
        b[x]+=v;
        x+=lowbit(x);
    }
}
inline int sm(int x)
{
    int ans=0;
    while(x>=1)
    {
        ans+=b[x];
        x-=lowbit(x);
    }
    return ans;
}
int main()
{
    scanf("%d",&n);
    for(int i=2;i<=n;i++)
        scanf("%d",&a[i]);
    for(int i=1;i<=n;i++)
        chg(i,1);
    for(int i=n;i>=1;i--)
    {
        int k=a[i]+1,l=0,r=n;
        while(l<r)
        {
            int mid=l+r>>1;
            if(sm(mid)<k)
                l=mid+1;
            else
                r=mid;
        }
        c[i]=l;
        chg(l,-1);
    }
    for(int i=1;i<=n;i++)
        printf("%d\n",c[i]);
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值