DP-HDOJ-5400-Arithmetic Sequence

Arithmetic Sequence

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1204 Accepted Submission(s): 526

Problem Description
A sequence b1,b2,⋯,bn are called (d1,d2)-arithmetic sequence if and only if there exist i(1≤i≤n) such that for every j(1 ≤ j < i),bj+1=bj+d1 and for every j(i ≤ j < n),bj+1=bj+d2.

Teacher Mai has a sequence a1,a2,⋯,an. He wants to know how many intervals l,r there are that al,al+1,⋯,ar are (d1,d2)-arithmetic sequence.

Input
There are multiple test cases.

For each test case, the first line contains three numbers n,d1,d2(1≤n≤105,|d1|,|d2|≤1000), the next line contains n integers a1,a2,⋯,an(|ai|≤109).

Output
For each test case, print the answer.

Sample Input
5 2 -2
0 2 0 -2 0
5 2 3
2 3 3 3 3

Sample Output
12
5

//
//  main.cpp
//  150818-1005
//
//  Created by 袁子涵 on 15/8/18.
//  Copyright (c) 2015年 袁子涵. All rights reserved.
//

#include <iostream>
#include <string.h>
#include <stdio.h>
#include <stdlib.h>

using namespace std;

long long int num[100010];
long long int head[100010];
long long int tail[100010];
unsigned long long int sum;

int d1,d2;
long int n;

void dp(long int x)
{
    if (x==n) {
        return;
    }
    //d1
    if (num[x]==num[x-1]+d1) {
        head[x]=head[x-1]+1;
        tail[x]=1;
        dp(x+1);
        return;
    }
    //d2
    if (num[x]==num[x-1]+d2) {
        head[x]=1;
        tail[x]=tail[x-1]+head[x-1];
        dp(x+1);
        return;
    }
    //其他
    else
    {
        head[x]=1;
        tail[x]=1;
        dp(x+1);
    }
    return;
}

int main(int argc, const char * argv[]) {
    while (scanf("%ld%d%d",&n,&d1,&d2)!=EOF) {
        memset(num, 0, sizeof(num));
        memset(head, 0, sizeof(head));
        memset(tail, 0, sizeof(tail));
        sum=0;
        for (long int i=0; i<n; i++) {
            scanf("%lld",&num[i]);
        }
        head[0]=1;
        tail[0]=1;
        dp(1);
        for (long int i=0; i<n; i++) {
            sum+=(head[i]+tail[i]-1);
        }
        printf("%llu\n",sum);
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值