DP-HDU-1260-Tickets

Tickets

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2082 Accepted Submission(s): 1008

Problem Description
Jesus, what a great movie! Thousands of people are rushing to the cinema. However, this is really a tuff time for Joe who sells the film tickets. He is wandering when could he go back home as early as possible.
A good approach, reducing the total time of tickets selling, is let adjacent people buy tickets together. As the restriction of the Ticket Seller Machine, Joe can sell a single ticket or two adjacent tickets at a time.
Since you are the great JESUS, you know exactly how much time needed for every person to buy a single ticket or two tickets for him/her. Could you so kind to tell poor Joe at what time could he go back home as early as possible? If so, I guess Joe would full of appreciation for your help.

Input
There are N(1<=N<=10) different scenarios, each scenario consists of 3 lines:
1) An integer K(1<=K<=2000) representing the total number of people;
2) K integer numbers(0s<=Si<=25s) representing the time consumed to buy a ticket for each person;
3) (K-1) integer numbers(0s<=Di<=50s) representing the time needed for two adjacent people to buy two tickets together.

Output
For every scenario, please tell Joe at what time could he go back home as early as possible. Every day Joe started his work at 08:00:00 am. The format of time is HH:MM:SS am|pm.

Sample Input
2
2
20 25
40
1
8

Sample Output
08:00:40 am
08:00:08 am

Source
浙江工业大学第四届大学生程序设计竞赛

水题,dp[i]=min(dp[i-1]+single[i],dp[i-2]+double[i]).
dp完处理一下时间输出即可。

//
//  main.cpp
//  基础DP1-H-Tickets
//
//  Created by 袁子涵 on 15/10/24.
//  Copyright © 2015年 袁子涵. All rights reserved.
//
//  0ms 1620KB

#include <iostream>
#include <string.h>
#include <stdlib.h>
#include <stdio.h>
#include <algorithm>
#include <math.h>

#define INF 0x7fffffff
#define MAX 2005

using namespace::std;

int N,k,single[MAX],db[MAX];
long long int dp[MAX],out;
int second,minute,hour,flag;

int main(int argc, const char * argv[]) {
    cin >> N;
    while (N--) {
        cin >> k;
        for (int i=1; i<=k; i++) {
            scanf("%d",&single[i]);
        }
        for (int i=2; i<=k; i++) {
            scanf("%d",&db[i]);
        }
        dp[0]=0;
        dp[1]=single[1];
        for (int i=2; i<=k; i++) {
            dp[i]=min(dp[i-1]+single[i],dp[i-2]+db[i]);
        }
        out=dp[k];
        hour=out/3600;
        out%=3600;
        minute=out/60;
        out%=60;
        second=out;
        hour+=8;
        if (hour/12) {
            hour%=12;
            flag=1;
        }
        else
            flag=0;
        printf("%02d:%02d:%02d ",hour,minute,second);
        if (flag) {
            printf("pm\n");
        }
        else
            printf("am\n");
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值