POJ-2387 Til the Cows Come Home【最短路】

题面:

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible.

Farmer John’s field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it.

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.
Input
* Line 1: Two integers: T and N

  • Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.
    Output
  • Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.
    Sample Input
    5 5
    1 2 20
    2 3 30
    3 4 20
    4 5 20
    1 5 100
    Sample Output
    90

题目大意:

现在有一个n个点的图,有t个通路,每一行给出一个路径和它的权值。
求从第1个到第n个点的最短路径并输出

大致思路:

Dijkstra裸题,把图建好跑一遍答案就出来了。但是!!我WA了10次!!
主要愿意有:
1.之前写的模板有一个细节写错了,而那个模板没有经过题目验证。导致我一直没有注意到这个问题。
2.可能有重边的情况,比如 :当输入为1 2 9和1 2 10的时候,由于没有考虑重边的情况,导致后面的一条边将前面的一条边覆盖,导致结果错误。

代码:

关于优先队列,我在WA的生无可恋的时候,看别人的博客。看到另外一种优先队列的写法,在这里mark一下

    typedef pair<int,int> pii;
    priority_queue<pii,vector<pii>,greater<pii> > q;
    q.push(make_pair(shortlen[start],start));

然后是我自己的代码:

#include<iostream>
#include<cstring>
#include<algorithm>
#include<queue>
#include<cstdio>
using namespace std;
const int maxn=2000+10;
const int INF=1<<30;
int shortlen[maxn];
int graph[maxn][maxn];
bool visit[maxn];
typedef struct Node{
    int dis,v;
    bool operator < (const Node &cmp)const{
        return dis > cmp.dis;
    }
}Node;
void Dijkstra(int start,int numv)
{
    priority_queue<Node> q;
    int value;
    shortlen[start]=0;
    q.push((Node){0,start});
    while(!q.empty())
    {
        Node a=q.top();
        q.pop();
        start=a.v;
        value=shortlen[start];
        if(visit[start])
            continue;
        visit[start]=true;
        for(int i=1;i<=numv;++i){
            if(i==start)
                continue;
            if(!visit[i]&&shortlen[i]>value+graph[start][i]){
                shortlen[i]=graph[start][i]+value;
                q.push((Node){shortlen[i],i});

            }
        }
    }
}
void Init(int num)
{
    for(int i=1;i<=num;++i){
        shortlen[i]=INF;
        visit[i]=false;
        for(int j=1;j<=num;++j)
            graph[i][j]=i==j?0:INF;
    }
}
int main()
{
    ios::sync_with_stdio(false);
    int t,num,x,y,w;
    while(cin>>t>>num)
    {
        Init(num);
        while(t--)
        {
            cin>>x>>y>>w;
            if(graph[x][y]>w){
                graph[x][y]=w;
                graph[y][x]=w;
            }
        }
        Dijkstra(1,num);
        cout<<shortlen[num]<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值