Countries in War poj 3114 (有向图的双连通分量+缩点+最短路flyod)

Countries in War
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 3794 Accepted: 1096

Description

In the year 2050, after different attempts of the UN to maintain peace in the world, the third world war broke out. The importance of industrial, commercial and military secrets obliges all the countries to use extremely sophisticated espionage services, so that each city in the world has at least one spy of each country. These spies need to communicate with other spies, informers as well as their headquarters during their actions. Unluckily there doesn’t exist a secure way for a spy to communicate during the war period, therefore the messages are always sent in code so that only the addressee is able to read the message and understand its meaning.

The spies use the only service that functions during the war period, the post. Each city has a postal agency where the letters are sent. The letters can be sent directly to their destination or to other postal agencies, until the letter arrives at the postal agency of the destination city, if possible.

The postal agency in city A can send a printed letter to the postal agency in city B if there is an agreement on sending letters, which determines the time, in hours, that a letter takes to reach city B from city A (and not necessarily the opposite). If there is no agreement between the agencies A and B, the agency A can try to send the letter to any agency so that the letter can reach its destination as early as possible

Some agencies are connected with electronic communication media, such as satellites and optical fibers. Before the war, these connections could reach all the agencies, making that a letter could be sent instantly. But during the period of hostilities every country starts to control electronic communication and an agency can only send a letter to another agency by electronic media (or instantly) if they are in the same country. Two agencies, A and B, are in the same country if a printed letter sent from any one of the agencies can be delivered to the other one.

The espionage service of your country has managed to obtain the content of all the agreements on sending messages existing in the world and desires to find out the minimum time to send a letter between different pairs of cities. Are you capable of helping them?

Input

The input contains several test cases. The first line of each test case contains two integer separated by a space, N (1 ≤ N ≤ 500) and E (0 ≤ E ≤ N2), indicating the numbers of cities (numbered from 1 to N) and of agreements on sending messages, respectively. Following them, then, E lines, each containing three integers separated by spaces, XY and H (1 ≤ XY ≤ N, 1 ≤ H ≤ 1000), indicating that there exist an agreement to send a printed letter from city X to city Y, and that such a letter will be delivered in H hours.

After that, there will be a line with an integer K (0 ≤ K ≤ 100), the number of queries. Finally, there will be K lines, each representing a query and containing two integers separated by a space, O and D (1 ≤ OD ≤ N). You must determine the minimum time to send a letter from city O to city D.

The end of the input is indicated by N = 0.

Output

For each test case your program should produce K lines of output. The I-th line should contain an integer M, the minimum time, in hours, to send a letter in the I-th query. If there aren’t communication media between the cities of the query, you should print “Nao e possivel entregar a carta” (“It’s impossible to deliver the letter”).

Print a blank line after each test case.

Sample Input

4 5
1 2 5
2 1 10
3 4 8
4 3 7
2 3 6
5
1 2
1 3
1 4
4 3
4 1
3 3
1 2 10
2 3 1
3 2 1
3
1 3
3 1
3 2
0 0

Sample Output

0
6
6
0
Nao e possivel entregar a carta

10
Nao e possivel entregar a carta
0
题目大意:

n个间谍 他们之间传送信息需要一定的时间一个联通分量里面的间谍属于一个国家,之间的信息传递不需要时间然后问你从一个间谍传一个信息到另一个间谍那需要最少时间 也可能传不到

思路:先缩点,再最短路,由于n最大只有500.可以用邻接矩阵

#include <stdio.h>
#include <string.h>

#define min(a,b) a>b?b:a
#define Max 505
int map[Max][Max];
struct Edge
{
    int to,w;
    int next;
}edge[Max * Max];

int head[Max],tol;
void add(int u,int v,int w)
{
    edge[tol].to = v;
    edge[tol].w = w;
    edge[tol].next = head[u];
    head[u] = tol++;
}

int dfn[Max],low[Max],Stack[Max],belong[Max];
int bcnt,time,top,instack[Max];

void tarjan( int u)
{
    dfn[u] = low[u] = ++time;
    Stack[top++] = u;
    instack[u] = true;

    for( int i = head[u]; i != -1; i = edge[i].next)
    {
        int v = edge[i].to;
        if(!dfn[v])
        {
            tarjan(v);
            low[u] = min(low[u], low[v]);
        }
        else
        {
            if( instack[v])
                low[u] = min(low[u], dfn[v]);
        }
    }
    int v;
    if(low[u] == dfn[u])
    {
        bcnt++;
        do
        {
            v = Stack[--top];
            instack[v] = false;
            belong[v] = bcnt;
        }while(u != v);
    }
}
int main()
{
    int n,m;
    int v,u,w;
    while(~scanf("%d%d", &n,&m))
    {
        if(!n && !m) break;
        memset(head, -1, sizeof(head));
        tol = 0;
        for(int i = 1; i <= m; i++)
        {
            int u, v, w;
            scanf("%d%d%d", &u, &v, &w);
            add(u,v,w);
        }

        memset(dfn, 0, sizeof(dfn));
        memset(low, 0, sizeof(low));
        top = time = bcnt = 0;

        for( int i = 1; i <= n; i++)
            if(!dfn[i])
              tarjan(i);

//        for( int i = 1; i <= n; i++)
//            printf("%d : %d\n",i,belong[i]);


          for(int  i = 1; i <= n; i++)
          {
              for( int j = 1; j <= n; j++)
                if( i == j)
                map[i][j] = 0;
              else map[i][j] = 0x3f3f3f3f;
          }

          for( u = 1; u <= n; u++)
          {
              for( int j = head[u]; j != -1; j = edge[j].next)
              {
                  v = edge[j].to;
                  w = edge[j].w;
                  if(belong[u] != belong[v])
                    map[belong[u]][belong[v]] = min(map[belong[u]][belong[v]],w);
              }
          }

          for( int k = 1; k <= bcnt; k++)
          {
              for( int i = 1; i <= bcnt; i++)
              {
                  for( int j = 1; j <= bcnt; j++)
                    if(map[i][j] > map[i][k] + map[k][j])
                      map[i][j] = map[i][k] + map[k][j];
              }
          }
          int t;
          scanf("%d",&t);
          while(t--)
          {
              scanf("%d%d",&u,&v);
              if(map[belong[u]][belong[v]] == 0x3f3f3f3f)
                printf("Nao e possivel entregar a carta\n");
              else
              printf("%d\n",map[belong[u]][belong[v]]);
          }
          printf("\n");
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值