【POJ】 2031 Building a Space Station

3 篇文章 0 订阅

Building a Space Station
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 6418 Accepted: 3156

Description

You are a member of the space station engineering team, and are assigned a task in the construction process of the station. You are expected to write a computer program to complete the task. 
The space station is made up with a number of units, called cells. All cells are sphere-shaped, but their sizes are not necessarily uniform. Each cell is fixed at its predetermined position shortly after the station is successfully put into its orbit. It is quite strange that two cells may be touching each other, or even may be overlapping. In an extreme case, a cell may be totally enclosing another one. I do not know how such arrangements are possible. 

All the cells must be connected, since crew members should be able to walk from any cell to any other cell. They can walk from a cell A to another cell B, if, (1) A and B are touching each other or overlapping, (2) A and B are connected by a `corridor', or (3) there is a cell C such that walking from A to C, and also from B to C are both possible. Note that the condition (3) should be interpreted transitively. 

You are expected to design a configuration, namely, which pairs of cells are to be connected with corridors. There is some freedom in the corridor configuration. For example, if there are three cells A, B and C, not touching nor overlapping each other, at least three plans are possible in order to connect all three cells. The first is to build corridors A-B and A-C, the second B-C and B-A, the third C-A and C-B. The cost of building a corridor is proportional to its length. Therefore, you should choose a plan with the shortest total length of the corridors. 

You can ignore the width of a corridor. A corridor is built between points on two cells' surfaces. It can be made arbitrarily long, but of course the shortest one is chosen. Even if two corridors A-B and C-D intersect in space, they are not considered to form a connection path between (for example) A and C. In other words, you may consider that two corridors never intersect. 

Input

The input consists of multiple data sets. Each data set is given in the following format. 


x1 y1 z1 r1 
x2 y2 z2 r2 
... 
xn yn zn rn 

The first line of a data set contains an integer n, which is the number of cells. n is positive, and does not exceed 100. 

The following n lines are descriptions of cells. Four values in a line are x-, y- and z-coordinates of the center, and radius (called r in the rest of the problem) of the sphere, in this order. Each value is given by a decimal fraction, with 3 digits after the decimal point. Values are separated by a space character. 

Each of x, y, z and r is positive and is less than 100.0. 

The end of the input is indicated by a line containing a zero. 

Output

For each data set, the shortest total length of the corridors should be printed, each in a separate line. The printed values should have 3 digits after the decimal point. They may not have an error greater than 0.001. 

Note that if no corridors are necessary, that is, if all the cells are connected without corridors, the shortest total length of the corridors is 0.000. 

Sample Input

3
10.000 10.000 50.000 10.000
40.000 10.000 50.000 10.000
40.000 40.000 50.000 10.000
2
30.000 30.000 30.000 20.000
40.000 40.000 40.000 20.000
5
5.729 15.143 3.996 25.837
6.013 14.372 4.818 10.671
80.115 63.292 84.477 15.120
64.095 80.924 70.029 14.881
39.472 85.116 71.369 5.553
0

Sample Output

20.000
0.000
73.834

题解:处理每个点的距离,并剪掉两个半径,处理成两点距离,处理完就直接最小生成树了。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <cstdlib>

using namespace std;

struct Edge
{
    int from,to,next;
    double d;
};
struct Edge e[10005];
double x[105],y[105],z[105],r[105],ans;
int father[105],n,pos[105];

double dis(int i,int j)
{
    double f=(x[i]-x[j])*(x[i]-x[j])+(y[i]-y[j])*(y[i]-y[j])+(z[i]-z[j])*(z[i]-z[j]);
    return max(sqrt(f)-r[i]-r[j],0.0);
}

int reset(int m)
{
    memset(e,0,sizeof(e));
    int h=1;
    for (int i=1;i<=m;i++)
        for (int j=1;j<i;j++)
        if (i!=j)
    {
        e[h].from=i; e[h].to=j; e[h].d=dis(i,j);
        e[h].next=pos[i]; pos[i]=h;
        h++;
    }
    return h-1;
}

void qsort(int low,int high)
{
    int i=low,j=high;
    double t=e[(i+j)/2].d;
    while (i<=j)
    {
        while (e[i].d<t) i++;
        while (e[j].d>t) j--;
        if (i<=j)
        {
            double k;
            k=e[i].d; e[i].d=e[j].d; e[j].d=k;
            int f;
            f=e[i].from; e[i].from=e[j].from; e[j].from=f;
            f=e[i].to; e[i].to=e[j].to; e[j].to=f;
            i++; j--;
        }
    }
    if (low<j) qsort(low,j);
    if (i<high) qsort(i,high);
}

int getfather(int k)
{
    if (father[k]==k) return k;
    else return father[k]=getfather(father[k]);
}

int main()
{
    while (scanf("%d",&n),n)
    {
        memset(x,0,sizeof(x));
        memset(y,0,sizeof(y));
        memset(z,0,sizeof(z));
        memset(e,0,sizeof(r));
        memset(father,0,sizeof(father));
        ans=0;
        for (int i=1;i<=n;i++) scanf("%lf%lf%lf%lf",&x[i],&y[i],&z[i],&r[i]);
        int h=reset(n);
        qsort(1,h);
        for (int i=1;i<=n;i++) father[i]=i;
        for (int i=1;i<=n*(n-1)/2;i++)
        {
            int a=getfather(e[i].from),b=getfather(e[i].to);
            if (a!=b)
            {
                ans+=e[i].d;
                father[a]=b;
            }
        }
        printf("%.3lf\n",ans);
    }
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值