A Famous ICPC Team

A Famous ICPC Team

时间限制: 1000 ms  |           内存限制: 65535 KB
难度:2
描述

Mr. B, Mr. G, Mr. M and their coach Professor S are planning their way to Warsaw for the ACM-ICPC World Finals. Each of the four has a square-shaped suitcase with side length Ai (1<=i<=4) respectively. They want to pack their suitcases into a large square box. The heights of the large box as well as the four suitcases are exactly the same. So they only need to consider the large box’s side length. Of course, you should write a program to output the minimum side length of the large box, so that the four suitcases can be put into the box without overlapping.

输入
Each test case contains only one line containing 4 integers Ai (1<=i<=4, 1<=Ai<=1,000,000,000) indicating the side length of each suitcase.
输出
For each test case, display a single line containing the case number and the minimum side length of the large box required.
样例输入
2 2 2 2
2 2 2 1
样例输出
1
2
Case 1: 4
Case 2: 4
Hint:
For the first case, all suitcases have size 2x2. 
So they can perfectly be packed in a 4x4 large 
box without wasting any space.For the second case, 
three suitcases have size 2x2 and the last one is 1x1. 
Nomatter how you rotate or move the suitcases, the side 
length of the large box mustbe at least 4.
#include <stdio.h>

void sort(int a[])   // 选择排序 
{
	int k;
	for(int i = 0; i < 3; i++)
	{
		k = i;
		for(int j = i + 1; j < 4; j++)
		if(a[k] > a[j])
		k = j;
		if(k != i)
		{
			int t = a[k];
			a[k] = a[i];
			a[i] = t;
		}
	}
}
int main()
{
	int a[4],Case = 1;
	while(scanf("%d%d%d%d",&a[0],&a[1],&a[2],&a[3]) != EOF)
	{
		sort(a);
		printf("Case %d: %d\n",Case++,a[2]+a[3]);     // 输出结果 
	}
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值