CocoaPods 使用

转载 2015年07月10日 09:54:18
CocoaPods详解之----使用篇
原文地址:http://blog.csdn.net/wzzvictory/article/details/18737437

一、什么是CocoaPods

1、为什么需要CocoaPods

在进行iOS开发的时候,总免不了使用第三方的开源库,比如SBJson、AFNetworking、Reachability等等。使用这些库的时候通常需要:

 

  • 下载开源库的源代码并引入工程
  • 向工程中添加开源库使用到的framework
  • 解决开源库和开源库以及开源库和工程之间的依赖关系、检查重复添加的framework等问题
  • 如果开源库有更新的时候,还需要将工程中使用的开源库删除,重新执行前面的三个步骤,顿时头都大了。。。

 

自从有了CocoaPods以后,这些繁杂的工作就不再需要我们亲力亲为了,只需要我们做好少量的配置工作,CocoaPods会为我们做好一切!

2、什么是CocoaPods

CocoaPods是一个用来帮助我们管理第三方依赖库的工具。它可以解决库与库之间的依赖关系,下载库的源代码,同时通过创建一个Xcode的workspace来将这些第三方库和我们的工程连接起来,供我们开发使用。

使用CocoaPods的目的是让我们能自动化的、集中的、直观的管理第三方开源库。


二、安装CocoaPods

1、安装

CocoaPods的核心组件

  1. sudo gem install cocoapods  
CocoaPods是以Ruby gem包的形式被安装的。在安装执行的过程中,可能会问我们是不是更新rake,输入y即可。这是因为rake gem包会在安装的过程中检查更细,如果有可用的新版本就会出现刚才的选项。

 

在安装进程结束的时候,执行命令:

  1. pod setup  
  2.    Setting up CocoaPods master repo  

        Setup completed (read-only access)  

如果没有报错,就说明一切安装就成功了!

这个时间可能会比较长!!!!!!!有可能等的时间很长。耐心等待下

 

2、安装过程中可能遇到的问题

①执行完install命令半天没反应

这有可能是因为Ruby的默认源使用的是cocoapods.org,国内访问这个网址有时候会有问题,网上的一种解决方案是将远替换成淘宝的,替换方式如下:

  1. gem sources --remove https://rubygems.org/  
  2. //等有反应之后再敲入以下命令  
  3. gem sources -a http://ruby.taobao.org/  
要想验证是否替换成功了,可以执行:
  1. gem sources -l  
正常的输出是:
  1. *** CURRENT SOURCES ***  
  2.   
  3. http://ruby.taobao.org/  

 

②gem版本过老

 

gem是管理Ruby库和程序的标准包,如果它的版本过低也可能导致安装失败,解决方案自然是升级gem,执行下述命令即可:

  1. sudo gem update --system  

 

③安装完成后,执行pod setup命令时报错:

  1. /Users/wangzz/.rvm/rubies/ruby-1.9.3-p448/lib/ruby/site_ruby/1.9.1/rubygems/dependency.rb:298:in `to_specs': Could not find 'cocoapods' (>= 0among 6 total gem(s) (Gem::LoadError)  
  2.     from /Users/wangzz/.rvm/rubies/ruby-1.9.3-p448/lib/ruby/site_ruby/1.9.1/rubygems/dependency.rb:309:in `to_spec'  
  3.     from /Users/wangzz/.rvm/rubies/ruby-1.9.3-p448/lib/ruby/site_ruby/1.9.1/rubygems/core_ext/kernel_gem.rb:53:in `gem'  
  4.     from /Users/wangzz/.rvm/rubies/ruby-1.9.3-p448/bin/pod:22:in `'  
这就是路径设置的问题,可以通过执行:
  1. rvm use ruby-1.9.3-p448  
解决该问题。

 

3、升级CocoaPods

升级很简单,再次执行安装命令即可:

  1. sudo gem install cocoapods  
需要注意的是,如果安装的时候使用了sudo,升级的时候一样需要使用该关键字,不然升级完了以后又会出现路径不匹配问题。

  (使用cocoapods 方法一:)

如何确定CocoaPods是否支持我们想要加入的目标类库?使用Search命令搜索类库名:


1.      pod search AFNetworking  

 

如果CocoaPods支持,将会输出搜索到的所有类库版本和信息,以及在Podfile中配置的写法,例如:

 

 


 

1.      -> AFNetworking (2.1.0)  

2.         delightful iOS and OS networking framework.  

3.         pod 'AFNetworking', '~> 2.1.0'  

4.         Homepage: https://github.com/AFNetworking/AFNetworking  

5.         Source:   https://github.com/AFNetworking/AFNetworking.git  

6.         Versions: 2.1.0, 2.0.3, 2.0.2, 2.0.1, 2.0.0-RC3, 2.0.0-RC2, 2.0.0-RC1,  

7.         2.0.0, 1.3.3, 1.3.2, 1.3.1, 1.3.0, 1.2.1, 1.2.0, 1.1.0, 1.0RC3, 1.0RC2,  

8.         1.0RC1, 1.0.1, 1.0, 0.9.2, 0.9.1, 0.9.0, 0.7.0, 0.5.1, 0.10.1, 0.10.0 [master  

9.         repo]  

10.       Sub specs:  

11.         AFNetworking/Serialization (2.1.0)  

12.         AFNetworking/Security (2.1.0)  

13.         AFNetworking/Reachability (2.1.0)  

14.         AFNetworking/NSURLConnection (2.1.0)  

15.         AFNetworking/NSURLSession (2.1.0)  

16.         AFNetworking/UIKit (2.1.0)  

17.      

18.      

19.    -> AFNetworking+AutoRetry (0.0.2)  

20.       Auto Retries for AFNetworking requests  

21.       pod 'AFNetworking+AutoRetry', '~> 0.0.2'  

22.       Homepage: https://github.com/shaioz/AFNetworking-AutoRetry  

23.       Source:   https://github.com/shaioz/AFNetworking-AutoRetry.git  

24.       Versions: 0.0.2, 0.0.1 [master repo]  

25.      

26.      

27.    -> AFNetworking-RACExtensions (0.1.2)  

28.       AFNetworking-RACExtensions is delightful extension to the AFNetworking  

29.       classes for iOS and Mac OS X.  

30.       pod 'AFNetworking-RACExtensions', '~> 0.1.2'  

31.       Homepage: https://github.com/CodaFi/AFNetworking-RACExtensions  

32.       Source:   https://github.com/CodaFi/AFNetworking-RACExtensions.git  

33.       Versions: 0.1.2, 0.1.1, 0.0.1 [master repo]  

34.      

35.      

36.    -> AFNetworking-ReactiveCocoa (0.0.2)  

37.       Make AFNetworking reactive.  

38.       pod 'AFNetworking-ReactiveCocoa', '~> 0.0.2'  

39.       Homepage: https://github.com/uasi/AFNetworking-ReactiveCocoa  

40.       Source:   https://github.com/uasi/AFNetworking-ReactiveCocoa.git  

41.       Versions: 0.0.2, 0.0.1 [master repo]  

42.      

43.      

44.    -> AFNetworking-Synchronous (0.2.0)  

45.       Synchronous requests for AFNetworking  

46.       pod 'AFNetworking-Synchronous', '~> 0.2.0'  

47.       Homepage: https://github.com/paulmelnikow/AFNetworking-Synchronous  

48.       Source:   https://github.com/paulmelnikow/AFNetworking-Synchronous.git  

49.       Versions: 0.2.0, 0.1.0 [master repo]  

好吧,进入主题,首先在我们的工程目录下创建Podfile文件,该文件用来控制CocoaPods的下载内容,该文件是没有后缀的,每个项目只需要一个Podfile文件,如果需要导入多个类库那么统一在该文件中书写下载内容。

创建过程:首先cd到工程目录,然后创建Podfile并且使用vim编写:如何使用vim编写<</span>在终端输入vim Podfile>然后回车,然后在出现的vim编辑器里面点击字母i,就可以进行编辑。

(命令行顺序输入:)
(假定工程放在在桌面可以通过cd  进入到工程里面)

1.   cd Desktop/CocoaPodsDemo/  

2.     touch Podfile

3.  $vim Podfile

然后按下字母i进行编辑。编辑见下:


1.      platform:ios, '7.0'  

2.      pod "AFNetworking", "~>2.1"  

3.                                                                                      

4.                                                                                      

5.                                                                                      

6.                                                                                      

7.                                                                                      

8.                                                                                      

9.                                                                                      

10.                                                                                    

11.                                                                                    

12.                                                                                    

13.                                                                                    

14.                                                                                    

15.                                                                                    

16.                                                                                    

17.                                                                                    

18.                                                                                    

19.                                                                                    

20.                                                                                    

21.                                                                                    

22.                                                                                    

23.                                                                                    

24.    :wq  

 

在编辑完成后先按esc,再按“:”,输入wq保存并退出。

Podfile中的两句文字的意思是,当前AFNetworking支持的iOS最高版本是iOS 7.0, 要下载的AFNetworking版本是2.1。(目前的最高版本是2.3.1

 

 

也可以用文本编辑工具打开该文件进行编辑,命令如下:(在编辑之前必须保证Podfile存在)

 


 

1.      open -e Podfile  

 

这里我同时为Demo安装AFNetworkingJSONKitMBProgressHUD三个类库,Podfile文件内容如下:

 


 

1.      platform:ios, '7.0'    

2.      pod 'AFNetworking', '~> 2.1.0'  

3.      pod 'JSONKit-NoWarning', '~> 1.1'  

4.      pod 'MBProgressHUD', '~> 0.8'  

 

 

在有了Podfile后,输入以下命令安装类库:

 


 

1.      pod install  

 

安装完成后,输出信息如下:

1.     pod install  

2.      Analyzing dependencies  

3.      Downloading dependencies  

4.      Installing AFNetworking (2.1.0)  

5.      Installing JSONKit-NoWarning (1.1)  

6.      Installing MBProgressHUD (0.8)  

7.      Generating Pods project  

8.      Integrating client project  

9.        

10.    [!] From now on use `CocoaPodsDemo.xcworkspace`.  

 

最后一句表明,如果要正确打开工程我们应该打开最新生成的.xcworkspace文件。

 

 

这里就可以看到工程目录发生变化了,三个类库都安装上了:

 

 

三、使用CocoaPods(方法二:)

如果之前做的一切顺利,接下来就可以体验体验CocoaPods的神奇之处了,需要经过以下几步:

为了演示这个过程,我创建了一个名为CocoaPodsTest的工程。

1、创建Podfile

CocoaPods的一切都是从一个名为Podfile的文件开始的,我们需要先创建这个文件。个人习惯使用命令行,我会这样做:

  1. cd /Users/wangzz/Desktop/CocoaPodsTest  
  2. touch Podfile  
首先进入到工程的根目录下,创建空白的Podfile文件,创建完毕的目录结构如下图:

 




2、编辑Podfile

根据需要,我们可以在Podfile文件中写入需要用到的第三方库,以SBJson、AFNetworking、Reachability三个库为例,我的Podfile内容如下:

  1. platform :ios  
  2. pod 'Reachability' '~> 3.0.0'  
  3. pod 'SBJson''~> 4.0.0'  
  4.   
  5. platform :ios, '7.0'  
  6. pod 'AFNetworking''~> 2.0'  

 

3、执行导入命令

 

准备工作都完成后,开始导入第三方库:

  1. cd /Users/wangzz/Desktop/CocoaPodsTest  
  2. pod install  
首先进入工程根目录,然后执行pod install命令,CocoaPods就开始为我们做下载源码、配置依赖关系、引入需要的framework等一些列工作,命令的执行结果打印出来如下:
  1. Analyzing dependencies  
  2. Downloading dependencies  
  3. Installing AFNetworking (2.1.0 
  4. Installing JSONKit (1.5pre 
  5. Installing Reachability (3.0.0 
  6. Generating Pods project  
  7. Integrating client project  
  8.   
  9. [!] From now on use `CocoaPodsTest.xcworkspace`.  
这就说明pod install命令执行成功了。再来看看工程根目录发生的变化,如下图:

 


可以看到,工程的根目录下多了三个东西:CocoaPodsTest.xcworkspace、Podfile.lock文件和Pods目录。



再看看刚才执行完pod install命令打印出来的内容的最后一行:

  1. [!] From now on use `CocoaPodsTest.xcworkspace`.  
提示我们从现在起,我们需要使用CocoaPodsTest.xcworkspace文件来开发。

 

对于工程发生的变化,有几点需要说明:

 

  • 第三方库会被编译成静态库供我们正真的工程使用

 

CocoaPods会将所有的第三方库以target的方式组成一个名为Pods的工程,该工程就放在刚才新生成的Pods目录下。整个第三方库工程会生成一个名称为libPods.a的静态库提供给我们自己的CocoaPodsTest工程使用。

 

  • 我们的工程和第三方库所在的工程会由一个新生成的workspace管理

 

为了方便我们直观的管理工程和第三方库,CocoaPodsTest工程和Pods工程会被以workspace的形式组织和管理,也就是我们刚才看到的CocoaPodsTest.xcworkspace文件。

原来的工程设置已经被更改了,这时候我们直接打开原来的工程文件去编译就会报错,只能使用新生成的workspace来进行项目管理。

打开CocoaPodsTest.xcworkspace,界面如下:

工程的目录结构还是非常明显的。

在项目中引用刚才添加的第三方库的头文件,执行编译操作,果断成功!

注意

如果一个项目中已经包含了CocoaPods的配置文件,但是编译却出现错误,那么我们仅需要一行命令就可以配置好所有的第三方类库了:

 pod update 

补充说明: 

 不           如果想在原来的基础上再次导入第三方可以在工程或者podfile中进行编辑,编辑过后在命令行中输入 pod install  把新添加的第三方导入到工程中,如果出现错误的话可以在终端输入 pod  update  进行版本的更新。

四、参考资料

1、http://code4app.com/article/cocoapods-install-usage

2、http://cocoapods.org/

相关文章推荐

CocoaPods安装使用

  • 2016年01月05日 10:36
  • 155KB
  • 下载

安装ruby环境(使用cocoaPods)

  • 2015年10月27日 10:11
  • 199KB
  • 下载

iOS库的介绍以及如何使用CocoaPods管理库(2016最新版本)

我们首先从操作系统的角度来讨论一下:如何将一个用户源程序变为一个可在内存中执行的程序? 这是一门令人蛋疼的课,幸好还有点卵用、 回答我们提出的问题: 1、 《编译》 作用:将用户源代码编...
  • IOSAFei
  • IOSAFei
  • 2016年05月31日 20:16
  • 5560

CocoaPods安装和使用教程

  • 2016年02月15日 14:04
  • 104KB
  • 下载

使用cocoapods下载第三方库

  • 2017年09月15日 14:03
  • 458KB
  • 下载

cocoapods 安装与使用

最近做得xiang CocoaPods这个软件,可以帮你管理Xcode里的第三方的库

CocoaPods安装和使用副本.pdf

  • 2015年10月19日 10:36
  • 1.36MB
  • 下载

cocoaPods使用

  • 2014年11月15日 15:20
  • 2.44MB
  • 下载

iOS开发:给项目工程里面添加Podfile配置文件,以及CocoaPods的简单使用

iOS开发中,新创建一个项目的时候,项目总目录里面没有pods的配置文件,实际上电脑上面是安装的有cocoapods的,那么下面我就介绍一下怎么给新建的项目工程里面添加podfile配置文件,以及包含...
  • CC1991_
  • CC1991_
  • 2017年08月04日 17:36
  • 849

cocoapods安装使用

  • 2017年06月27日 10:18
  • 608KB
  • 下载
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:CocoaPods 使用
举报原因:
原因补充:

(最多只允许输入30个字)