HDU 1061 Rightmost Digit

链接:http://acm.hdu.edu.cn/showproblem.php?pid=1061

Rightmost Digit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 39835    Accepted Submission(s): 15036

Problem Description

Given a positive integer N, you should output the most right digit of N^N.

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).

Output

For each test case, you should output the rightmost digit of N^N.

Sample Input

  
  
2 3 4

Sample Output

  
  
7 6
Hint
In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7. In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.

Author
Ignatius.L

Recommend

大意——给你一个正整数n,要你算出n^n的最后一位数码。其中1<=n<=1,000,000,000。


思路——与HDU 1097差不多,我们可以用二分求快速幂,并且边乘边模,这样的话就不会出问题了。


复杂度分析——时间复杂度:O(log(n)),空间复杂度:O(1)


附上AC代码:


#include <iostream>
#include <cstdio>
#include <string>
#include <cmath>
#include <iomanip>
#include <ctime>
#include <climits>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <queue>
#include <vector>
#include <set>
#include <map>
using namespace std;
typedef unsigned int UI;
typedef long long LL;
typedef unsigned long long ULL;
typedef long double LD;
const double pi = acos(-1.0);
const double e = exp(1.0);
const double eps = 1e-8;
const int mod = 10;

int quick_pow(int a);

int main()
{
	ios::sync_with_stdio(false);
	int T, a;
	scanf("%d", &T);
	while (T--)
	{
		scanf("%d", &a);
		printf("%d\n", quick_pow(a));
	}
	return 0;
}

int quick_pow(int a)
{
	int res = 1;
	int b = a;
	while (b > 0)
	{
		if (b & 1)
			res = ((res%mod)*(a%mod))%mod;
		a = ((a%mod)*(a%mod))%mod;
		b >>= 1;
	}
	return res;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值