oil deposits——广搜

Oil Deposits
Problem Description
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either *’, representing the absence of oil, or@’, representing an oil pocket.

Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input
1 1
*
3 5
@@*
@
@@*
1 8
@@*@
5 5
**@
@@@
@*@
@@@*@
@@**@
0 0

Sample Output
0
1
2
2
大致题意:遇到‘@’便在八个方向搜索,同样是‘@’化为一堆,计算一共有几堆。

以下是AC代码(用广搜做的):

#include<stdio.h>
#include<math.h>
#include<string.h>
#include<queue>
using namespace std;
int book[105][105];//标记已经被搜索过的油田
int n,m;
int f[8][2]={{1,0},{0,1},{0,-1},{-1,0},{1,1},{1,-1},{-1,1},{-1,-1}};//在八个方向进行搜索
char aa[105][105];
struct lyf
{
    int x,y;
};
int bfs(int a,int b)
{
    lyf yy,ff;
    yy.x=a;
    yy.y=b;
    queue<lyf>q;
    q.push(yy);
    while(!q.empty())
    {
        ff=q.front();
        q.pop();
        int i;
        for(i=0;i<8;i++)
        {
            yy.x=ff.x+f[i][0];
            yy.y=ff.y+f[i][1];
            if(yy.x>=0&&yy.x<n&&yy.y>=0&&yy.y<m&&
               book[yy.x][yy.y]==0&&aa[yy.x][yy.y]=='@')
            {
                aa[yy.x][yy.y]='*';//将遍及过的油田转化为‘*’,以免再次被搜到,其实是和book一样的功能
                book[yy.x][yy.y]=1;
                q.push(yy);//搜到的油田进入队列,按照先进先出的顺序,依次对每块油田向它的八个方向搜索
            }
        }
    }
}
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        if(n==0&&m==0)
        {
            return 0;
        }
        memset(book,0,sizeof(book));
        int i,j;
        for(i=0;i<n;i++)
        {
            scanf("%s",&aa[i]);
        }
        int s;
        s=0;
        for(i=0;i<n;i++)
        {
            for(j=0;j<m;j++)
            {
                if(aa[i][j]=='@')
                {
                    book[i][j]=1;
                    bfs(i,j);
                    s++;
                }
            }
        }
        printf("%d\n",s);
    }
}

题目传送门:Oil Deposits(点击可交题)

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值