数据结构实验之排序八:快速排序 (sdut oj)


数据结构实验之排序八:快速排序

Time Limit: 1000MS  Memory Limit: 65536KB


Problem Description
给定N(N≤10^5)个整数,要求用快速排序对数据进行升序排列,注意不得使用STL。
 
Input
 连续输入多组数据,每组输入数据第一行给出正整数N(≤10^5),随后给出N个整数,数字间以空格分隔。
Output
 输出排序后的结果,数字间以一个空格间隔,行末不得有多余空格。
Example Input
8
49 38 65 97 76 13 27 49
Example Output
13 27 38 49 49 65 76 97
Hint
 
Author




参考代码



#include<stdio.h>

int a[100000];

void sort(int l,int r)
{
    int key = a[l];
    int i = l, j = r;
    int temp;
    while( i < j )
    {
        while( i < j &&  key <= a[j] ) j--;
        a[i] = a[j];
        while( i < j && key >= a[i] ) i++;
        a[j] = a[i];
    }
    a[i] = key;
    if( l < r )
    {
        sort(i+1,r);
        sort(l,i-1);
    }
}

void Output(int n)
{
     int i;
     for( i = 0; i < n; i++ )
     {
        if( i == n - 1 )
        printf("%d\n",a[i]);
        else
        printf("%d ",a[i]);
     }
}

int main()
{
    int n,i;
    while(~scanf("%d",&n))
    {
        for( i = 0; i < n; i++ )
        {
              scanf("%d",a+i);
        }
        sort(0,n-1);
        Output(n);
    }
    return 0;
}


  • 0
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值