POJ-1860(最短路)

Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency. 
For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR. 
You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges, and real R  AB, C  AB, R  BA and C  BA - exchange rates and commissions when exchanging A to B and B to A respectively. 
Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations. 
Input
The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain 6 numbers each - the description of the corresponding exchange point - in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=10  3
For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10  -2<=rate<=10  2, 0<=commission<=10  2
Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 10  4
Output
If Nick can increase his wealth, output YES, in other case output NO to the output file.
Sample Input
3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00
Sample Output
YES

/*
题意:输入n,m,s,v分别代表:有n种货币,有m个地方可以进行货币交换,
      你起始的货币种类,你起始货币种类的数目
      循环m次接下来输入a,b,rab,cab,rba,cba分别代表a——>b交换
	  rab:把a换成b的汇率,cab:a换成b的手续费;
	  问经过重复的交换是否可以使初始货币的总量增加

分析:一种货币就是一个点一个“兑换点”就是图上两种货币之间的一个
	  兑换方式,是双边,但A到B的汇率和手续费可能与B到A的汇率和手续费不同。
      唯一值得注意的是权值,当拥有货币A的数量为V时,A到A的权值为K,即没有兑换
	  而A到B的权值为(V-Cab)*Rab本题是“求最大路径”,之所以被归类为“求最小路径”
	  是因为本题题恰恰与bellman-Ford算法的松弛条件相反,求的是能无限松弛的最大正
	  权路径,但是依然能够利用bellman-Ford的思想去解题。
	  因此初始化dis(S)=V   而源点到其他点的距离(权值)初始化为无穷小(0),
	  当s到其他某点的距离能不断变大时,说明存在最大路径;如果可以一直变大,
	  说明存在正环。判断是否存在环路,用Bellman-Ford和spfa都可以。


*/




#include<math.h>
#include<stdio.h>
#include<iostream>
#include<queue>
#include<string.h>
using namespace std;
double dis[105], rate[105][105], cost[105][105];
int n, m, s, vis[105];
double v;

bool spfa()
{
	memset(vis, 0, sizeof(vis));
	memset(dis, 0, sizeof(dis));
	dis[s] = v;
	queue<int>q;
	q.push(s);
	vis[s] = 1;
	while (!q.empty())
	{
		int temp = q.front();
		q.pop();
		vis[temp] = 0;
		for (int i = 0; i <= n; i++)
		{
			if (dis[i] < (dis[temp] - cost[temp][i])*rate[temp][i])
			{
				dis[i] = (dis[temp] - cost[temp][i])*rate[temp][i];
				if (dis[s] > v)
				{
					return true;
				}
				if (!vis[i])
				{
					q.push(i);
					vis[i] = 1;
				}
			}
		}
	}
	return false;
}



int main()
{

	while (cin >> n >> m >> s >> v)
	{
		int a, b;
		double rab, rba, cab, cba;
		//初始化
		for (int i = 1; i <= n; i++)
		{
			for (int j = 1; j <= n; j++)
			{
				if (i == j)
				{
					rate[i][j] == 1;
				}
				else
					rate[i][j] = 0;
				cost[i][j] = 0;
			}
		}




		for (int i = 0; i < m; i++)
		{
			cin >> a >> b >> rab >> cab >> rba >> cba;
			rate[a][b] = rab;
			rate[b][a] = rba;
			cost[a][b] = cab;
			cost[b][a] = cba;
		}

		if (spfa())
		{
			cout << "YES" << endl;
		}
		else
		{
			cout << "NO" << endl;
		}

	}
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值