HIT 2430 Counting the algorithms (树状数组)

Counting the algorithms

My Tags  (Edit)
  Source : mostleg
  Time limit : 1 sec   Memory limit : 64 M

Submitted : 788, Accepted : 312

As most of the ACMers, wy's next target is algorithms, too. wy is clever, so he can learn most of the algorithms quickly. After a short time, he has learned a lot. One day, mostleg asked him that how many he had learned. That was really a hard problem, so wy wanted to change to count other things to distract mostleg's attention. The following problem will tell you what wy counted.

Given 2N integers in a line, in which each integer in the range from 1 to N will appear exactly twice. You job is to choose one integer each time and erase the two of its appearances and get a mark calculated by the differece of there position. For example, if the first 3 is in position 86 and the second 3 is in position 88, you can get 2 marks if you choose to erase 3 at this time. You should notice that after one turn of erasing, integers' positions may change, that is, vacant positions (without integer) in front of non-vacant positions is not allowed.

Input

There are multiply test cases. Each test case contains two lines.

The first line: one integer N(1 <= N <= 100000).

The second line: 2N integers. You can assume that each integer in [1,N] will appear just twice.

Output

One line for each test case, the maximum mark you can get.

Sample Input

3
1 2 3 1 2 3
3
1 2 3 3 2 1

Sample Output

6
9

Hint

We can explain the second sample as this. First, erase 1, you get 6-1=5 marks. Then erase 2, you get 4-1=3 marks. You may notice that in the beginning, the two 2s are at positions 2 and 5, but at this time, they are at positions 1 and 4. At last erase 3, you get 2-1=1marks. Therefore, in total you get 5+3+1=9 and that is the best strategy.



题目大意:

可以直接看样例和HINT, 就是从一个队列中拿走相同的,然后位置差作为得分,使得分尽量要高。

分析:

很有意思的小题目。考虑三种情况 AABB     ABAB    ABBA 可知第一种情况我随意拿都可以, 第二种情况不管怎么拿都会让之后的操作所得数字-1, 第三种情况我应该先拿外面,里面相对位置不变。

然后树状数组中记录下所有的数字,第一次出现就标记为1 第二次出现标记为-1。 从前往后遍历, 求得第i个的配对元素j之后还有多少个-1即可,就是ABAB情况的对数。



#include<cstdio>
#include <cmath>
#include <vector>
#include <complex>
#include<cstdlib>
#include<string.h>
#include <iostream>
#include <algorithm>
#define MAX 200100


struct node{
	int f, s;
}st[MAX];

int arr[MAX];
long long int m_arr[MAX];
bool oc[MAX];

int lowbit(int n){
	return n & (-n);
}
void update(int p, int n){
	while(p < MAX){
		m_arr[p] += n;
		p += lowbit(p);
	}
}
long long int get(int p){
	long long int res = 0;
	while(p > 0){
		res += m_arr[p];
		p -= lowbit(p);
	}
	return res;
}




int main()
{
	int num, i, tmp;
	long long int res;
	while(~scanf("%d", &num)){
		res = 0;
		memset(oc, 0, sizeof(oc));

		num *= 2;
		for(i = 1; i <= num; i++){
			scanf("%d", &arr[i]);
			if(oc[arr[i]]){
				res += i - st[arr[i]].f;
				update(i, -1);
				st[arr[i]].s = i;
			}
			else{
				update(i, 1);
				oc[arr[i]] = 1;
				st[arr[i]].f = i;
			}
		}
			
		memset(oc, 0 ,sizeof(oc));
		for(i = 1; i <= num; i++){
			if(oc[arr[i]]) continue;
			oc[arr[i]] = 1;
			tmp = - get(num) + get(st[arr[i]].s);
			update(st[arr[i]].s, 1);
			update(st[arr[i]].f, -1);
			res -= tmp;
		}
		printf("%lld\n", res);
		

	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值