POJ 2342 Anniversary party (树形dp 入门题)


Anniversary party
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4810 Accepted: 2724

Description

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.

Input

Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go N – 1 lines that describe a supervisor relation tree. Each line of the tree specification has the form:
L K
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line
0 0

Output

Output should contain the maximal sum of guests' ratings.

Sample Input

7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0

Sample Output

5

Source

Ural State University Internal Contest October'2000 Students Session

题目链接:http://poj.org/problem?id=2342

题目大意:一棵树,每个节点有一个值,现在要从中选一些点,要求这些点值和最大并且每对儿子和父亲不能同时被选

题目分析:dp[i][0]和dp[i][1]分别表示不选和选第i个点时以i为子树根时子树值的和,则:
dp[fa[i]][1] += dp[i][0]  表示选i的父亲时,其值等于自身值加上不选i时的值
dp[fa[i]][0] += max(dp[i][1], dp[i][0])  表示不选父亲时,则其值等于其儿子被选或没被选的值的最大值

#include <cstdio>
#include <cstring>
#include <vector>
#include <algorithm>
using namespace std;
int const MAX = 6005;
int dp[MAX][2], val[MAX];
bool vis[MAX], flag[MAX];
vector <int> vt[MAX];

void DFS(int fa)
{
    vis[fa] = true;
    dp[fa][1] = val[fa];
    int sz = vt[fa].size();
    for(int i = 0; i < sz; i++)
    {
        int son = vt[fa][i];
        if(!vis[son])
        {
            DFS(son);
            dp[fa][1] += dp[son][0];
            dp[fa][0] += max(dp[son][1], dp[son][0]);
        }
    }
    return;
}

int main()
{
    int n;
    while(scanf("%d", &n) && n)
    {
        for(int i = 1; i <= n; i++)
            vt[i].clear();
        memset(flag, false, sizeof(flag));
        memset(vis, false, sizeof(vis));
        memset(dp, 0, sizeof(dp));
        for(int i = 1; i <= n; i++)
            scanf("%d", &val[i]);
        for(int i = 0; i < n - 1; i++)
        {
            int a, b;
            scanf("%d %d", &a, &b);
            vt[b].push_back(a);
            flag[a] = true;
        }
        int root;
        for(int i = 1; i <= n; i++) //n个点n-1条边,必然存在“入度”为0的点即树根
        {
            if(!flag[i])
            {
                root = i;
                break;
            }
        }
        DFS(root);
        printf("%d\n", max(dp[root][1], dp[root][0]));
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值