HDU 5389 Zero Escape (类0/1背包)


Zero Escape

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)

Total Submission(s): 883    Accepted Submission(s): 452

Problem Description
Zero Escape, is a visual novel adventure video game directed by Kotaro Uchikoshi (you may hear about ever17?) and developed by Chunsoft.

Stilwell is enjoying the first chapter of this series, and in this chapter digital root is an important factor.

This is the definition of digital root on Wikipedia:
The digital root of a non-negative integer is the single digit value obtained by an iterative process of summing digits, on each iteration using the result from the previous iteration to compute a digit sum. The process continues until a single-digit number is reached.
For example, the digital root of 65536 is 7 , because 6+5+5+3+6=25 and 2+5=7 .

In the game, every player has a special identifier. Maybe two players have the same identifier, but they are different players. If a group of players want to get into a door numbered X(1X9) , the digital root of their identifier sum must be X .
For example, players {1,2,6} can get into the door 9 , but players {2,3,3} can't.

There is two doors, numbered A and B . Maybe A=B , but they are two different door.
And there is n players, everyone must get into one of these two doors. Some players will get into the door A , and others will get into the door B .
For example:
players are {1,2,6} , A=9 , B=1
There is only one way to distribute the players: all players get into the door 9 . Because there is no player to get into the door 1 , the digital root limit of this door will be ignored.

Given the identifier of every player, please calculate how many kinds of methods are there, mod 258280327 .
 
Input
The first line of the input contains a single number T , the number of test cases.
For each test case, the first line contains three integers n , A and B .
Next line contains n integers idi , describing the identifier of every player.
T100 , n105 , n106 , 1A,B,idi9
 
Output
For each test case, output a single integer in a single line, the number of ways that these n players can get into these two doors.
 
Sample Input
  
  
4 3 9 1 1 2 6 3 9 1 2 3 3 5 2 3 1 1 1 1 1 9 9 9 1 2 3 4 5 6 7 8 9
 
Sample Output
  
  
1 0 10 60

Source
 

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5389

题目大意:一群人每人有个号idi,两个门A B分别有个值,现在要把这群人分成两组(可以有一组为空)进入两个门,要求每组id和的数字根与门的值相同

题目分析:数字根直接mod 9就行了,随然公式是(x - 1) % 9 + 1,但是这里只要对不同的作区分即可,先判断(sum % 9)是不是不等于(A + B) % 9,如果是,则显然只可能把人全放到一个门里,这时候有三种情况,一个门都不行;只能进一个门;和两个门值相同,两个门都可以进,特判完,可以进行dp,dp[i][j]表示前i个人中进A门,数字根为j的可能数,这里不用管B,因为一共就两门,不是进A就是进B,dp[i][(j + a[i]) % 9] = dp[i][(j + a[i]) % 9] + dp[i - 1][j],即放或者不放,最后答案为dp[n][A % 9]


#include <cstdio>
#include <cstring>
#define ll long long
using namespace std;
int const MOD = 258280327;
int const MAX = 100005;
int a[MAX], dp[MAX][11];

int main()
{
    int T;
    scanf("%d", &T);
    while(T --) 
    {
        int n, A, B;
        memset(dp, 0, sizeof(dp));
        dp[0][0] = 1;
        int sum = 0;
        scanf("%d %d %d", &n, &A ,&B);
        for(int i = 1; i <= n; i++)
        {
            scanf("%d", &a[i]);
            sum += a[i];
        }
        if(sum % 9 != (A + B) % 9)
        {
            if(sum % 9 != A % 9 && sum % 9 != B % 9)
                printf("0\n");
            else
                printf("%d\n", A == B ? 2 : 1);
        }
        else 
        {
            for(int i = 1; i <= n; i++) 
            {
                for(int j = 0; j < 9; j++)
                    dp[i][j] = (dp[i][j] % MOD + dp[i - 1][j] % MOD) % MOD;
                for(int j = 0; j < 9; j++) 
                    dp[i][(j + a[i]) % 9] = (dp[i][(j + a[i]) % 9] % MOD + dp[i - 1][j] % MOD) % MOD;
            }
            printf("%d\n", dp[n][A % 9]);
        }
    }
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值