HDU 1222 Wolf and Rabbit (扩展欧几里德应用)

78 篇文章 0 订阅


Wolf and Rabbit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 6292    Accepted Submission(s): 3142

Problem Description
There is a hill with n holes around. The holes are signed from 0 to n-1.



A rabbit must hide in one of the holes. A wolf searches the rabbit in anticlockwise order. The first hole he get into is the one signed with 0. Then he will get into the hole every m holes. For example, m=2 and n=6, the wolf will get into the holes which are signed 0,2,4,0. If the rabbit hides in the hole which signed 1,3 or 5, she will survive. So we call these holes the safe holes.

Input
The input starts with a positive integer P which indicates the number of test cases. Then on the following P lines,each line consists 2 positive integer m and n(0<m,n<2147483648).
 
Output
For each input m n, if safe holes exist, you should output "YES", else output "NO" in a single line.

Sample Input
  
  
2 1 2 2 2

Sample Output
  
  
NO YES
 
Source
杭州电子科技大学第三届程序设计大赛

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1222

题目大意:n个数0 ~ n-1,现在从0开始每次可到距离自己逆时针方向m个数的地方,问是否有数字能不被访问到

题目分析:题是水题,yy一下就能出来,gcd(n, m) == 1时都能被访问到,下面给出证明:
显然走了a次m步所到的位置为pos = am % n = am - (am / n) * n,令am / n = -b,可以得到pos = am + bn (b < 0,0 <= pos < n),根据扩展欧几里德算法我们知道对于不定方程am + bn = gcd(n, m) = pos一定有解,因此只要是gcd(n, m)的倍数的数都能被访问到,所以当gcd(n, m) = 1时,pos可以为0 ~ n - 1的任意一个


#include <cstdio>

int gcd(int a, int b)
{
    return b ? gcd(b, a % b) : a;
}

int main()
{
    int T, n, m;
    scanf("%d", &T);

    while(T--)
    {
        scanf("%d %d", &n, &m);
        printf("%s\n", gcd(n, m) == 1 ? "NO" : "YES");
    }
}


 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值