ZOJ 2588 Burning Bridges (Tarjan 求割边)

91 篇文章 1 订阅


Burning Bridges

Time Limit: 5 Seconds      Memory Limit: 32768 KB

Ferry Kingdom is a nice little country located on N islands that are connected by M bridges. All bridgesare very beautiful and are loved by everyone in the kingdom. Of course, the system of bridges is designedin such a way that one can get from any island to any other one.

But recently the great sorrow has come to the kingdom. Ferry Kingdom was conquered by the armiesof the great warrior Jordan and he has decided to burn all the bridges that connected the islands. Thiswas a very cruel decision, but the wizards of Jordan have advised him no to do so, because after thathis own armies would not be able to get from one island to another. So Jordan decided to burn as manybridges as possible so that is was still possible for his armies to get from any island to any other one.

Now the poor people of Ferry Kingdom wonder what bridges will be burned. Of course, they cannotlearn that, because the list of bridges to be burned is kept in great secret. However, one old man saidthat you can help them to find the set of bridges that certainly will not be burned.

So they came to you and asked for help. Can you do that?


Input

The input contains multiple test cases. The first line of the input is a single integer T (1 <= T <= 20)which is the number of test cases. T test cases follow, each preceded by a single blank line.

The first line of each case contains N and M - the number of islands and bridges in Ferry Kingdomrespectively (2 <= N <= 10 000, 1 <= M <= 100 000). Next M lines contain two different integer numberseach and describe bridges. Note that there can be several bridges between a pair of islands.


Output

On the first line of each case print K - the number of bridges that will certainly not be burned.On the second line print K integers - the numbers of these bridges. Bridges are numbered starting fromone, as they are given in the input.

Two consecutive cases should be separated by a single blank line.No blank line should be produced after the last test case.


Sample Input

2

6 7
1 2
2 3
2 4
5 4
1 3
4 5
3 6

10 16
2 6
3 7
6 5
5 9
5 4
1 2
9 8
6 4
2 10
3 8
7 9
1 4
2 4
10 5
1 6
6 10

Sample Output

2
3 7

1
4 


Author: Andrew Stankevich
Source: Andrew Stankevich's Contest #5


题目链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=1588


题目大意:求割边,有重边


题目分析:裸的求割边,Tarjan算法,注意判重边,输出格式也很坑

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int const MAX = 1e5 + 5;
int low[MAX], dfn[MAX], head[MAX], ans[MAX];
bool vis[MAX];
int n, m, cnt, num;
struct EDGE
{
    int v, next;
    int id;
    bool mul;
}e[2 * MAX];

void Init()
{
    cnt = 0;
    num = 0;
    memset(head, -1, sizeof(head));
    memset(vis, false, sizeof(vis));
}

void Add(int u, int v, int id)
{
    for(int i = head[u]; i != -1; i = e[i].next)
    {
        if(e[i].v == v)
        {
            e[i].mul = true;
            return;
        }
    }
    e[cnt].id = id;
    e[cnt].v = v;
    e[cnt].next = head[u];
    head[u] = cnt ++;

    e[cnt].id = id;
    e[cnt].v = u;
    e[cnt].next = head[v];
    head[v] = cnt ++;
} 

void DFS(int u, int fa, int dep)
{
    vis[u] = true;
    dfn[u] = low[u] = dep;   
    for(int i = head[u]; i != -1; i = e[i].next)
    {
        int v = e[i].v;
        if(!vis[v])
        {
            DFS(v, u, dep + 1);
            low[u] = min(low[u], low[v]);
            if(low[v] > dfn[u] && !e[i].mul)
                ans[num ++] = e[i].id;
        }
        else
        {
            if(v != fa)
                low[u] = min(low[u], dfn[v]);
        }
    }
    return;
}

int main()
{
    int T;
    scanf("%d", &T);
    while(T --)
    {
        Init();
        scanf("%d %d", &n, &m);
        for(int i = 1; i <= m; i++)
        {
            int u, v;
            scanf("%d %d", &u, &v);
            Add(u, v, i);
        }
        DFS(1, 1, 0);
        sort(ans, ans + num);
        printf("%d\n", num);
        for(int i = 0; i < num - 1; i++)
            printf("%d ", ans[i]);
        if(num)
            printf("%d\n", ans[num - 1]);
        if(T)
            printf("\n");
    }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值