POJ 2184 Cow Exhibition (01背包变形 + 技巧 好题)

Cow Exhibition
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10847 Accepted: 4286

Description

"Fat and docile, big and dumb, they look so stupid, they aren't much 
fun..." 
- Cows with Guns by Dana Lyons 

The cows want to prove to the public that they are both smart and fun. In order to do this, Bessie has organized an exhibition that will be put on by the cows. She has given each of the N (1 <= N <= 100) cows a thorough interview and determined two values for each cow: the smartness Si (-1000 <= Si <= 1000) of the cow and the funness Fi (-1000 <= Fi <= 1000) of the cow. 

Bessie must choose which cows she wants to bring to her exhibition. She believes that the total smartness TS of the group is the sum of the Si's and, likewise, the total funness TF of the group is the sum of the Fi's. Bessie wants to maximize the sum of TS and TF, but she also wants both of these values to be non-negative (since she must also show that the cows are well-rounded; a negative TS or TF would ruin this). Help Bessie maximize the sum of TS and TF without letting either of these values become negative. 

Input

* Line 1: A single integer N, the number of cows 

* Lines 2..N+1: Two space-separated integers Si and Fi, respectively the smartness and funness for each cow. 

Output

* Line 1: One integer: the optimal sum of TS and TF such that both TS and TF are non-negative. If no subset of the cows has non-negative TS and non- negative TF, print 0. 

Sample Input

5
-5 7
8 -6
6 -3
2 1
-8 -5

Sample Output

8

Hint

OUTPUT DETAILS: 
Bessie chooses cows 1, 3, and 4, giving values of TS = -5+6+2 = 3 and TF 
= 7-3+1 = 5, so 3+5 = 8. Note that adding cow 2 would improve the value 
of TS+TF to 10, but the new value of TF would be negative, so it is not 
allowed. 

Source



题目大意:每个奶牛有一个s值和一个f值,现在要求选出一些奶牛他们的s值和f值的和最大,且他们的f值的和,s值的和都不能小于0

题目分析:最简单的想法三维dp,显然在时间和空间上都是不允许的,第一个技巧是通过普通01背包的思想先去掉第一维的n,对于正数就是倒叙循环,然后把第二维的s做为数组的下标,第三维的f做为数组的值,则降为1维,设dp[i]表示s和值为i时s和与f和的和的最大值(是不是很拗口?),因为可能为负,所以直接加一个大数字,本题单个和的最大为100000,则拿100000当做0点,所以数组要开到200000,根据01背包,正数倒推,负数正推,原因是要保证是用i-1的状态来修改i的状态,然后在j >= 100000且dp[j] >= 0时,取ans的最大值即可,有一个优化,如果s[i]和f[i]都是负数,则不需要加进去判断,因为加进去显然不会影响最优解
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int const MAX = 105;
int const CON = 200000;
int const INF = 1 << 30;
int dp[CON + 5], s[MAX], f[MAX];

int main()
{
	int n, ans = 0;
	scanf("%d" ,&n);
	for(int i = 0; i < n; i++)
		scanf("%d %d", &s[i], &f[i]);
	for(int i = 0; i <= CON; i++)
		dp[i] = -INF;
	dp[CON / 2] = 0;
	for(int i = 0; i < n; i++)
	{
		if(s[i] > 0 || f[i] > 0)
		{
			if(s[i] > 0)
			{
				for(int j = CON; j >= s[i]; j--)
				{
					if(dp[j - s[i]] > -INF)
					{
						dp[j] = max(dp[j], dp[j - s[i]] + f[i]);
						if(j >= CON / 2 && dp[j] > 0)
							ans = max(ans, dp[j] + j - CON / 2);
					}
				}
			}
			else
			{
				for(int j = s[i]; j <= CON + s[i]; j++)
				{
					if(dp[j - s[i]] > -INF)
					{
						dp[j] = max(dp[j], dp[j - s[i]] + f[i]);
						if(j >= CON / 2 && dp[j] > 0)
							ans = max(ans, dp[j] + j - CON / 2);
					}
				}
			}
		}
	}
	printf("%d\n", ans);
}



  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值