POJ 2528 Mayor's posters (线段树区间更新 + 离散化)

Mayor's posters
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 52874 Accepted: 15402

Description

The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral posters at all places at their whim. The city council has finally decided to build an electoral wall for placing the posters and introduce the following rules: 
  • Every candidate can place exactly one poster on the wall. 
  • All posters are of the same height equal to the height of the wall; the width of a poster can be any integer number of bytes (byte is the unit of length in Bytetown). 
  • The wall is divided into segments and the width of each segment is one byte. 
  • Each poster must completely cover a contiguous number of wall segments.

They have built a wall 10000000 bytes long (such that there is enough place for all candidates). When the electoral campaign was restarted, the candidates were placing their posters on the wall and their posters differed widely in width. Moreover, the candidates started placing their posters on wall segments already occupied by other posters. Everyone in Bytetown was curious whose posters will be visible (entirely or in part) on the last day before elections. 
Your task is to find the number of visible posters when all the posters are placed given the information about posters' size, their place and order of placement on the electoral wall. 

Input

The first line of input contains a number c giving the number of cases that follow. The first line of data for a single case contains number 1 <= n <= 10000. The subsequent n lines describe the posters in the order in which they were placed. The i-th line among the n lines contains two integer numbers l i and ri which are the number of the wall segment occupied by the left end and the right end of the i-th poster, respectively. We know that for each 1 <= i <= n, 1 <= l i <= ri <= 10000000. After the i-th poster is placed, it entirely covers all wall segments numbered l i, l i+1 ,... , ri.

Output

For each input data set print the number of visible posters after all the posters are placed. 

The picture below illustrates the case of the sample input. 

Sample Input

1
5
1 4
2 6
8 10
3 4
7 10

Sample Output

4

Source

Alberta Collegiate Programming Contest 2003.10.18


题目大意:后贴的海报覆盖先贴的,问最后区间能看到几张海报(不一定要看到整张)

题目分析:开始刚好理解错,当成后贴的放在先贴的下面了,wa成狗,不过不要紧,直接把for循环顺序变一下就行了,由于区间范围太大,直接建树肯定gg,所以采用离散化,sort+unique不要太方便,这题数据很神奇,用map的时间是用数组的10倍,用数组的内存是用map的10倍,不过都可过~
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <map>
#define lson l, mid, rt << 1
#define rson mid + 1, r, rt << 1 | 1
using namespace std;
int const MAX =  1e4 + 5;
int const MAXM = 1e7 + 5;
//map <int, int> chg;
int chg[MAXM];

int x[MAX * 2];
bool col[MAX << 2];

struct DATA
{
    int l, r;
}d[MAX];

void PushUp(int rt)
{
    col[rt] = (col[rt << 1] & col[rt << 1 | 1]); 
}

void PushDown(int rt)
{
    if(col[rt])
    {
        col[rt << 1] = col[rt];
        col[rt << 1 | 1] = col[rt];
        col[rt] = false;
    }
}

bool Update(int L, int R, int l, int r, int rt)
{
    if(L <= l && r <= R)
    {
        if(!col[rt])
        {
            col[rt] = true;
            return true;
        }
        return false;
    }
    bool f = false;
    PushDown(rt);
    int mid = (l + r) >> 1;
    if(L <= mid)
        f |= Update(L, R, lson);
    if(mid < R)
        f |= Update(L, R, rson);
    PushUp(rt);
    return f;
}

int main()
{
    int T;
    scanf("%d", &T);
    while(T --)
    {
        memset(col, false, sizeof(col));
        int n, ans = 0, cnt = 0;
        scanf("%d", &n);
        for(int i = 0; i < n; i++)
        {
            scanf("%d %d", &d[i].l, &d[i].r);
            x[cnt ++] = d[i].l;
            x[cnt ++] = d[i].r;
        }
        sort(x, x + cnt);
        cnt = unique(x, x + cnt) - x;
        for(int i = 0; i < cnt; i++)
            chg[x[i]] = i + 1;
        for(int i = n - 1; i >= 0; i--)
            if(Update(chg[d[i].l], chg[d[i].r], 1, cnt, 1))
                ans ++;
        printf("%d\n", ans);
    }
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值